summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/ccache/ccache_3.7.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/ccache/ccache_3.7.10.bb')
-rw-r--r--meta/recipes-devtools/ccache/ccache_3.7.10.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-devtools/ccache/ccache_3.7.10.bb b/meta/recipes-devtools/ccache/ccache_3.7.10.bb
new file mode 100644
index 0000000000..852583dfd2
--- /dev/null
+++ b/meta/recipes-devtools/ccache/ccache_3.7.10.bb
@@ -0,0 +1,32 @@
1SUMMARY = "a fast C/C++ compiler cache"
2DESCRIPTION = "ccache is a compiler cache. It speeds up recompilation \
3by caching the result of previous compilations and detecting when the \
4same compilation is being done again. Supported languages are C, C\+\+, \
5Objective-C and Objective-C++."
6HOMEPAGE = "http://ccache.samba.org"
7SECTION = "devel"
8
9LICENSE = "GPLv3+"
10LIC_FILES_CHKSUM = "file://LICENSE.adoc;md5=22d514dbc01fdf9a9784334b6b59417a"
11
12DEPENDS = "zlib"
13
14SRC_URI = "https://github.com/ccache/ccache/releases/download/v${PV}/${BP}.tar.gz"
15SRC_URI[sha256sum] = "447ddf21a5f0ffa6b6d26839ae876a6d17d0d7e3533926cdf78ecd11dad793f8"
16
17UPSTREAM_CHECK_URI = "https://github.com/ccache/ccache/releases/"
18
19inherit autotools
20
21# Remove ccache-native's dependencies, so that it can be used widely by
22# other native recipes.
23DEPENDS_class-native = ""
24EXTRA_OECONF_class-native = "--with-bundled-zlib"
25INHIBIT_AUTOTOOLS_DEPS_class-native = "1"
26PATCHTOOL = "patch"
27
28BBCLASSEXTEND = "native"
29
30do_configure_class-native() {
31 oe_runconf
32}