diff options
Diffstat (limited to 'meta/recipes-devtools/btrfs-tools/btrfs-tools_5.19.bb')
-rw-r--r-- | meta/recipes-devtools/btrfs-tools/btrfs-tools_5.19.bb | 72 |
1 files changed, 72 insertions, 0 deletions
diff --git a/meta/recipes-devtools/btrfs-tools/btrfs-tools_5.19.bb b/meta/recipes-devtools/btrfs-tools/btrfs-tools_5.19.bb new file mode 100644 index 0000000000..4f116a85ac --- /dev/null +++ b/meta/recipes-devtools/btrfs-tools/btrfs-tools_5.19.bb | |||
@@ -0,0 +1,72 @@ | |||
1 | SUMMARY = "Checksumming Copy on Write Filesystem utilities" | ||
2 | DESCRIPTION = "Btrfs is a new copy on write filesystem for Linux aimed at \ | ||
3 | implementing advanced features while focusing on fault tolerance, repair and \ | ||
4 | easy administration. \ | ||
5 | This package contains utilities (mkfs, fsck, btrfsctl) used to work with \ | ||
6 | btrfs and an utility (btrfs-convert) to make a btrfs filesystem from an ext3." | ||
7 | |||
8 | HOMEPAGE = "https://btrfs.wiki.kernel.org" | ||
9 | |||
10 | LICENSE = "GPL-2.0-only & LGPL-2.1-or-later" | ||
11 | LIC_FILES_CHKSUM = " \ | ||
12 | file://COPYING;md5=fcb02dc552a041dee27e4b85c7396067 \ | ||
13 | file://libbtrfsutil/COPYING;md5=4fbd65380cdd255951079008b364516c \ | ||
14 | " | ||
15 | SECTION = "base" | ||
16 | DEPENDS = "util-linux zlib" | ||
17 | |||
18 | SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/kdave/btrfs-progs.git;branch=master \ | ||
19 | file://0001-Add-a-possibility-to-specify-where-python-modules-ar.patch \ | ||
20 | " | ||
21 | SRCREV = "96b83b16158f3b87037085761bf212e958473767" | ||
22 | S = "${WORKDIR}/git" | ||
23 | |||
24 | PACKAGECONFIG ??= " \ | ||
25 | programs \ | ||
26 | convert \ | ||
27 | python \ | ||
28 | crypto-builtin \ | ||
29 | " | ||
30 | PACKAGECONFIG[manpages] = "--enable-documentation, --disable-documentation, python3-sphinx-native" | ||
31 | PACKAGECONFIG[programs] = "--enable-programs,--disable-programs" | ||
32 | PACKAGECONFIG[convert] = "--enable-convert --with-convert=ext2,--disable-convert --without-convert,e2fsprogs" | ||
33 | PACKAGECONFIG[zoned] = "--enable-zoned,--disable-zoned" | ||
34 | PACKAGECONFIG[python] = "--enable-python,--disable-python,python3-setuptools-native" | ||
35 | PACKAGECONFIG[lzo] = "--enable-lzo,--disable-lzo,lzo" | ||
36 | PACKAGECONFIG[zstd] = "--enable-zstd,--disable-zstd,zstd" | ||
37 | PACKAGECONFIG[udev] = "--enable-libudev,--disable-libudev,udev" | ||
38 | |||
39 | # Pick only one crypto provider | ||
40 | PACKAGECONFIG[crypto-builtin] = "--with-crypto=builtin" | ||
41 | PACKAGECONFIG[crypto-libgcrypt] = "--with-crypto=libgcrypt,,libgcrypt" | ||
42 | PACKAGECONFIG[crypto-libsodium] = "--with-crypto=libsodium,,libsodium" | ||
43 | PACKAGECONFIG[crypto-libkcapi] = "--with-crypto=libkcapi,,libkcapi" | ||
44 | |||
45 | inherit autotools-brokensep pkgconfig manpages | ||
46 | inherit ${@bb.utils.contains('PACKAGECONFIG', 'python', 'setuptools3-base', '', d)} | ||
47 | |||
48 | CLEANBROKEN = "1" | ||
49 | |||
50 | EXTRA_OECONF = "--enable-largefile" | ||
51 | EXTRA_OECONF:append:libc-musl = " --disable-backtrace " | ||
52 | EXTRA_PYTHON_CFLAGS = "${DEBUG_PREFIX_MAP}" | ||
53 | EXTRA_PYTHON_CFLAGS:class-native = "" | ||
54 | EXTRA_PYTHON_LDFLAGS = "${LDFLAGS}" | ||
55 | EXTRA_OEMAKE = "V=1 'EXTRA_PYTHON_CFLAGS=${EXTRA_PYTHON_CFLAGS}' 'EXTRA_PYTHON_LDFLAGS=${EXTRA_PYTHON_LDFLAGS}'" | ||
56 | |||
57 | do_configure:prepend() { | ||
58 | # Upstream doesn't ship this and autoreconf won't install it as automake isn't used. | ||
59 | mkdir -p ${S}/config | ||
60 | cp -f $(automake --print-libdir)/install-sh ${S}/config/ | ||
61 | } | ||
62 | |||
63 | |||
64 | do_install:append() { | ||
65 | if [ "${@bb.utils.filter('PACKAGECONFIG', 'python', d)}" ]; then | ||
66 | oe_runmake 'DESTDIR=${D}' 'PYTHON_SITEPACKAGES_DIR=${PYTHON_SITEPACKAGES_DIR}' install_python | ||
67 | fi | ||
68 | } | ||
69 | |||
70 | RDEPENDS:${PN} = "libgcc" | ||
71 | |||
72 | BBCLASSEXTEND = "native nativesdk" | ||