summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/btrfs-tools/btrfs-tools_4.19.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/btrfs-tools/btrfs-tools_4.19.bb')
-rw-r--r--meta/recipes-devtools/btrfs-tools/btrfs-tools_4.19.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta/recipes-devtools/btrfs-tools/btrfs-tools_4.19.bb b/meta/recipes-devtools/btrfs-tools/btrfs-tools_4.19.bb
new file mode 100644
index 0000000000..f5e0f77c8a
--- /dev/null
+++ b/meta/recipes-devtools/btrfs-tools/btrfs-tools_4.19.bb
@@ -0,0 +1,45 @@
1SUMMARY = "Checksumming Copy on Write Filesystem utilities"
2DESCRIPTION = "Btrfs is a new copy on write filesystem for Linux aimed at \
3implementing advanced features while focusing on fault tolerance, repair and \
4easy administration. \
5This package contains utilities (mkfs, fsck, btrfsctl) used to work with \
6btrfs and an utility (btrfs-convert) to make a btrfs filesystem from an ext3."
7
8HOMEPAGE = "https://btrfs.wiki.kernel.org"
9
10LICENSE = "GPLv2"
11LIC_FILES_CHKSUM = "file://COPYING;md5=fcb02dc552a041dee27e4b85c7396067"
12SECTION = "base"
13DEPENDS = "util-linux attr e2fsprogs lzo acl python3-setuptools-native"
14DEPENDS_append_class-target = " udev"
15RDEPENDS_${PN} = "libgcc"
16
17SRCREV = "d72d913291683188ddf5d758db02f1bc3b05d2f7"
18SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/kdave/btrfs-progs.git \
19 file://0001-Makefile-build-mktables-using-native-gcc.patch \
20 file://0001-Add-LDFLAGS-when-building-libbtrfsutil.so.patch \
21 file://0001-Add-a-possibility-to-specify-where-python-modules-ar.patch \
22 file://0001-btrfs-progs-kernel-lib-bitops-Fix-big-endian-compila.patch \
23 "
24
25inherit autotools-brokensep pkgconfig manpages distutils3-base
26
27CLEANBROKEN = "1"
28
29PACKAGECONFIG[manpages] = "--enable-documentation, --disable-documentation, asciidoc-native xmlto-native"
30EXTRA_OECONF = " --disable-zstd"
31EXTRA_OECONF_append_libc-musl = " --disable-backtrace "
32
33do_configure_prepend() {
34 # Upstream doesn't ship this and autoreconf won't install it as automake isn't used.
35 mkdir -p ${S}/config
36 cp -f $(automake --print-libdir)/install-sh ${S}/config/
37}
38
39S = "${WORKDIR}/git"
40
41do_install_append() {
42 oe_runmake 'DESTDIR=${D}' 'PYTHON_SITEPACKAGES_DIR=${PYTHON_SITEPACKAGES_DIR}' install_python
43}
44
45BBCLASSEXTEND = "native"