summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/btrfs-tools/btrfs-tools_4.15.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/btrfs-tools/btrfs-tools_4.15.1.bb')
-rw-r--r--meta/recipes-devtools/btrfs-tools/btrfs-tools_4.15.1.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-devtools/btrfs-tools/btrfs-tools_4.15.1.bb b/meta/recipes-devtools/btrfs-tools/btrfs-tools_4.15.1.bb
new file mode 100644
index 0000000000..f7ea27321c
--- /dev/null
+++ b/meta/recipes-devtools/btrfs-tools/btrfs-tools_4.15.1.bb
@@ -0,0 +1,39 @@
1SUMMARY = "Checksumming Copy on Write Filesystem utilities"
2DESCRIPTION = "Btrfs is a new copy on write filesystem for Linux aimed at \
3implementing advanced features while focusing on fault tolerance, repair and \
4easy administration. \
5This package contains utilities (mkfs, fsck, btrfsctl) used to work with \
6btrfs and an utility (btrfs-convert) to make a btrfs filesystem from an ext3."
7
8HOMEPAGE = "https://btrfs.wiki.kernel.org"
9
10LICENSE = "GPLv2"
11LIC_FILES_CHKSUM = "file://COPYING;md5=fcb02dc552a041dee27e4b85c7396067"
12SECTION = "base"
13DEPENDS = "util-linux attr e2fsprogs lzo acl"
14DEPENDS_append_class-target = " udev"
15RDEPENDS_${PN} = "libgcc"
16
17SRCREV = "3097f02c948f69f520c565ff8f8ba476aa6edb88"
18SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/kdave/btrfs-progs.git \
19 file://0001-Makefile-build-mktables-using-native-gcc.patch \
20 file://ftw-subdir-walk.patch \
21 "
22
23inherit autotools-brokensep pkgconfig manpages
24
25CLEANBROKEN = "1"
26
27PACKAGECONFIG[manpages] = "--enable-documentation, --disable-documentation, asciidoc-native xmlto-native"
28EXTRA_OECONF = " --disable-zstd"
29EXTRA_OECONF_append_libc-musl = " --disable-backtrace "
30
31do_configure_prepend() {
32 # Upstream doesn't ship this and autoreconf won't install it as automake isn't used.
33 mkdir -p ${S}/config
34 cp -f $(automake --print-libdir)/install-sh ${S}/config/
35}
36
37S = "${WORKDIR}/git"
38
39BBCLASSEXTEND = "native"