summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/bison/bison_3.5.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/bison/bison_3.5.4.bb')
-rw-r--r--meta/recipes-devtools/bison/bison_3.5.4.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta/recipes-devtools/bison/bison_3.5.4.bb b/meta/recipes-devtools/bison/bison_3.5.4.bb
new file mode 100644
index 0000000000..9830721038
--- /dev/null
+++ b/meta/recipes-devtools/bison/bison_3.5.4.bb
@@ -0,0 +1,45 @@
1SUMMARY = "GNU Project parser generator (yacc replacement)"
2DESCRIPTION = "Bison is a general-purpose parser generator that converts an annotated context-free grammar into \
3an LALR(1) or GLR parser for that grammar. Bison is upward compatible with Yacc: all properly-written Yacc \
4grammars ought to work with Bison with no change. Anyone familiar with Yacc should be able to use Bison with \
5little trouble."
6HOMEPAGE = "http://www.gnu.org/software/bison/"
7LICENSE = "GPLv3"
8LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
9SECTION = "devel"
10DEPENDS = "bison-native flex-native"
11
12SRC_URI = "${GNU_MIRROR}/bison/bison-${PV}.tar.xz \
13 file://dont-depend-on-help2man.patch.patch \
14 file://add-with-bisonlocaledir.patch \
15 file://0001-bison-fix-the-parallel-build.patch \
16"
17SRC_URI[sha256sum] = "4c17e99881978fa32c05933c5262457fa5b2b611668454f8dc2a695cd6b3720c"
18
19# No point in hardcoding path to m4, just use PATH
20EXTRA_OECONF += "M4=m4"
21
22# Reset any loadavg set via environment, it breaks parallel build
23# | ../bison-3.5.2/lib/uniwidth/width.c:21:10: fatal error: uniwidth.h: No such file or directory
24# | #include "uniwidth.h"
25# | ^~~~~~~~~~~~
26EXTRA_OEMAKE_append = " -l"
27
28inherit autotools gettext texinfo
29
30# The automatic m4 path detection gets confused, so force the right value
31acpaths = "-I ./m4"
32
33do_compile_prepend() {
34 for i in mfcalc calc++ rpcalc; do mkdir -p ${B}/examples/$i; done
35}
36
37do_install_append_class-native() {
38 create_wrapper ${D}/${bindir}/bison \
39 BISON_PKGDATADIR=${STAGING_DATADIR_NATIVE}/bison
40}
41do_install_append_class-nativesdk() {
42 create_wrapper ${D}/${bindir}/bison \
43 BISON_PKGDATADIR=${datadir}/bison
44}
45BBCLASSEXTEND = "native nativesdk"