summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/bison/bison_2.5.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/bison/bison_2.5.1.bb')
-rw-r--r--meta/recipes-devtools/bison/bison_2.5.1.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-devtools/bison/bison_2.5.1.bb b/meta/recipes-devtools/bison/bison_2.5.1.bb
new file mode 100644
index 0000000000..d53c1d64a3
--- /dev/null
+++ b/meta/recipes-devtools/bison/bison_2.5.1.bb
@@ -0,0 +1,36 @@
1SUMMARY = "GNU Project parser generator (yacc replacement)."
2DESCRIPTION = "Bison is a general-purpose parser generator that converts an annotated context-free grammar into \
3an LALR(1) or GLR parser for that grammar. Bison is upward compatible with Yacc: all properly-written Yacc \
4grammars ought to work with Bison with no change. Anyone familiar with Yacc should be able to use Bison with \
5little trouble."
6HOMEPAGE = "http://www.gnu.org/software/bison/"
7LICENSE = "GPLv3"
8LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
9SECTION = "devel"
10DEPENDS = "bison-native flex-native"
11
12BASE_SRC_URI = "${GNU_MIRROR}/bison/bison-${PV}.tar.gz \
13 file://m4.patch \
14 "
15
16SRC_URI = "${BASE_SRC_URI} \
17 file://fix_cross_manpage_building.patch \
18 "
19
20SRC_URI[md5sum] = "8fedf916f1aa2c4a31441d8f8bbc603c"
21SRC_URI[sha256sum] = "48dc3649231b75ac160d73528000ec89b6cd8d3b87cb7d0713f72ef4610442d4"
22
23LDFLAGS_prepend_libc-uclibc = " -lrt "
24DEPENDS_virtclass-native = "gettext-minimal-native"
25SRC_URI_virtclass-native = "${BASE_SRC_URI}"
26
27inherit autotools gettext
28acpaths = "-I ${S}/m4"
29
30do_install_append_virtclass-native() {
31 create_wrapper ${D}/${bindir}/bison \
32 M4=${STAGING_BINDIR_NATIVE}/m4 \
33 BISON_PKGDATADIR=${STAGING_DATADIR_NATIVE}/bison
34}
35#bison-native encodes the staging M4 path
36BBCLASSEXTEND = "native"