summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/automake/automake_1.16.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/automake/automake_1.16.1.bb')
-rw-r--r--meta/recipes-devtools/automake/automake_1.16.1.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta/recipes-devtools/automake/automake_1.16.1.bb b/meta/recipes-devtools/automake/automake_1.16.1.bb
new file mode 100644
index 0000000000..c64ee44d90
--- /dev/null
+++ b/meta/recipes-devtools/automake/automake_1.16.1.bb
@@ -0,0 +1,43 @@
1require automake.inc
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
4DEPENDS_class-native = "autoconf-native"
5
6NAMEVER = "${@oe.utils.trim_version("${PV}", 2)}"
7
8RDEPENDS_${PN} += "\
9 autoconf \
10 perl \
11 perl-module-bytes \
12 perl-module-data-dumper \
13 perl-module-strict \
14 perl-module-text-parsewords \
15 perl-module-thread-queue \
16 perl-module-threads \
17 perl-module-vars "
18
19RDEPENDS_${PN}_class-native = "autoconf-native hostperl-runtime-native"
20RDEPENDS_${PN}_class-nativesdk = "nativesdk-autoconf"
21
22SRC_URI += "file://python-libdir.patch \
23 file://buildtest.patch \
24 file://performance.patch \
25 file://new_rt_path_for_test-driver.patch \
26 file://automake-replace-w-option-in-shebangs-with-modern-use-warnings.patch \
27 file://0001-automake-Add-default-libtool_tag-to-cppasm.patch \
28 "
29
30SRC_URI[md5sum] = "83cc2463a4080efd46a72ba2c9f6b8f5"
31SRC_URI[sha256sum] = "608a97523f97db32f1f5d5615c98ca69326ced2054c9f82e65bade7fc4c9dea8"
32
33PERL = "${USRBINPATH}/perl"
34PERL_class-native = "${USRBINPATH}/env perl"
35PERL_class-nativesdk = "${USRBINPATH}/env perl"
36
37CACHED_CONFIGUREVARS += "ac_cv_path_PERL='${PERL}'"
38
39do_install_append () {
40 install -d ${D}${datadir}
41}
42
43BBCLASSEXTEND = "native nativesdk"