summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/automake/automake_1.15.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/automake/automake_1.15.1.bb')
-rw-r--r--meta/recipes-devtools/automake/automake_1.15.1.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta/recipes-devtools/automake/automake_1.15.1.bb b/meta/recipes-devtools/automake/automake_1.15.1.bb
new file mode 100644
index 0000000000..481234185e
--- /dev/null
+++ b/meta/recipes-devtools/automake/automake_1.15.1.bb
@@ -0,0 +1,42 @@
1require automake.inc
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
4DEPENDS_class-native = "autoconf-native"
5
6NAMEVER = "${@oe.utils.trim_version("${PV}", 2)}"
7
8RDEPENDS_${PN} += "\
9 autoconf \
10 perl \
11 perl-module-bytes \
12 perl-module-data-dumper \
13 perl-module-strict \
14 perl-module-text-parsewords \
15 perl-module-thread-queue \
16 perl-module-threads \
17 perl-module-vars "
18
19RDEPENDS_${PN}_class-native = "autoconf-native hostperl-runtime-native"
20RDEPENDS_${PN}_class-nativesdk = "nativesdk-autoconf"
21
22SRC_URI += "file://python-libdir.patch \
23 file://buildtest.patch \
24 file://performance.patch \
25 file://new_rt_path_for_test-driver.patch \
26 file://automake-replace-w-option-in-shebangs-with-modern-use-warnings.patch \
27 "
28
29SRC_URI[md5sum] = "95df3f2d6eb8f81e70b8cb63a93c8853"
30SRC_URI[sha256sum] = "988e32527abe052307d21c8ca000aa238b914df363a617e38f4fb89f5abf6260"
31
32PERL = "${USRBINPATH}/perl"
33PERL_class-native = "${USRBINPATH}/env perl"
34PERL_class-nativesdk = "${USRBINPATH}/env perl"
35
36CACHED_CONFIGUREVARS += "ac_cv_path_PERL='${PERL}'"
37
38do_install_append () {
39 install -d ${D}${datadir}
40}
41
42BBCLASSEXTEND = "native nativesdk"