summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/automake/automake_1.14.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/automake/automake_1.14.bb')
-rw-r--r--meta/recipes-devtools/automake/automake_1.14.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta/recipes-devtools/automake/automake_1.14.bb b/meta/recipes-devtools/automake/automake_1.14.bb
new file mode 100644
index 0000000000..de6fcfa648
--- /dev/null
+++ b/meta/recipes-devtools/automake/automake_1.14.bb
@@ -0,0 +1,42 @@
1require automake.inc
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
4DEPENDS_class-native = "autoconf-native"
5
6NAMEVER = "${@oe.utils.trim_version("${PV}", 2)}"
7
8RDEPENDS_${PN} += "\
9 autoconf \
10 perl \
11 perl-module-bytes \
12 perl-module-data-dumper \
13 perl-module-strict \
14 perl-module-text-parsewords \
15 perl-module-thread-queue \
16 perl-module-threads \
17 perl-module-vars "
18
19RDEPENDS_${PN}_class-native = "autoconf-native perl-native-runtime"
20
21SRC_URI += " file://python-libdir.patch \
22 file://py-compile-compile-only-optimized-byte-code.patch \
23 file://buildtest.patch"
24
25SRC_URI[md5sum] = "a3c0d9298c6112f5f2c26c639ccaaed7"
26SRC_URI[sha256sum] = "7847424d4204d1627c129e9c15b81e145836afa2a1bf9003ffe10aa26ea75755"
27
28do_install_append () {
29 install -d ${D}${datadir}
30
31 # Some distros have both /bin/perl and /usr/bin/perl, but we set perl location
32 # for target as /usr/bin/perl, so fix it to /usr/bin/perl.
33 for i in aclocal aclocal-${NAMEVER} automake automake-${NAMEVER}; do
34 if [ -f ${D}${bindir}/$i ]; then
35 sed -i -e '1s,#!.*perl,#! ${USRBINPATH}/perl,' \
36 -e 's,exec .*/bin/perl \(.*\) exec .*/bin/perl \(.*\),exec ${USRBINPATH}/perl \1 exec ${USRBINPATH}/perl \2,' \
37 ${D}${bindir}/$i
38 fi
39 done
40}
41
42BBCLASSEXTEND = "native nativesdk"