summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/automake/automake_1.14.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/automake/automake_1.14.1.bb')
-rw-r--r--meta/recipes-devtools/automake/automake_1.14.1.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta/recipes-devtools/automake/automake_1.14.1.bb b/meta/recipes-devtools/automake/automake_1.14.1.bb
new file mode 100644
index 0000000000..3a13a34b84
--- /dev/null
+++ b/meta/recipes-devtools/automake/automake_1.14.1.bb
@@ -0,0 +1,43 @@
1require automake.inc
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
4DEPENDS_class-native = "autoconf-native"
5
6NAMEVER = "${@oe.utils.trim_version("${PV}", 2)}"
7
8RDEPENDS_${PN} += "\
9 autoconf \
10 perl \
11 perl-module-bytes \
12 perl-module-data-dumper \
13 perl-module-strict \
14 perl-module-text-parsewords \
15 perl-module-thread-queue \
16 perl-module-threads \
17 perl-module-vars "
18
19RDEPENDS_${PN}_class-native = "autoconf-native perl-native-runtime"
20
21SRC_URI += " file://python-libdir.patch \
22 file://py-compile-compile-only-optimized-byte-code.patch \
23 file://buildtest.patch \
24 file://new_rt_path_for_test-driver.patch"
25
26SRC_URI[md5sum] = "d052a3e884631b9c7892f2efce542d75"
27SRC_URI[sha256sum] = "814c2333f350ce00034a1fe718e0e4239998ceea7b0aff67e9fd273ed6dfc23b"
28
29do_install_append () {
30 install -d ${D}${datadir}
31
32 # Some distros have both /bin/perl and /usr/bin/perl, but we set perl location
33 # for target as /usr/bin/perl, so fix it to /usr/bin/perl.
34 for i in aclocal aclocal-${NAMEVER} automake automake-${NAMEVER}; do
35 if [ -f ${D}${bindir}/$i ]; then
36 sed -i -e '1s,#!.*perl,#! ${USRBINPATH}/perl,' \
37 -e 's,exec .*/bin/perl \(.*\) exec .*/bin/perl \(.*\),exec ${USRBINPATH}/perl \1 exec ${USRBINPATH}/perl \2,' \
38 ${D}${bindir}/$i
39 fi
40 done
41}
42
43BBCLASSEXTEND = "native nativesdk"