summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/automake/automake_1.13.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/automake/automake_1.13.4.bb')
-rw-r--r--meta/recipes-devtools/automake/automake_1.13.4.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/meta/recipes-devtools/automake/automake_1.13.4.bb b/meta/recipes-devtools/automake/automake_1.13.4.bb
new file mode 100644
index 0000000000..b114d990ce
--- /dev/null
+++ b/meta/recipes-devtools/automake/automake_1.13.4.bb
@@ -0,0 +1,48 @@
1require automake.inc
2LICENSE="GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
4DEPENDS_class-native = "autoconf-native"
5
6NAMEVER = "${@oe.utils.trim_version("${PV}", 2)}"
7
8RDEPENDS_${PN} += "\
9 autoconf \
10 perl \
11 perl-module-bytes \
12 perl-module-data-dumper \
13 perl-module-strict \
14 perl-module-text-parsewords \
15 perl-module-thread-queue \
16 perl-module-threads \
17 perl-module-vars "
18
19RDEPENDS_${PN}_class-native = "autoconf-native perl-native-runtime"
20
21PATHFIXPATCH = "file://path_prog_fixes.patch"
22PATHFIXPATCH_class-native = ""
23PATHFIXPATCH_class-nativesdk = ""
24
25SRC_URI += "${PATHFIXPATCH} \
26 file://prefer-cpio-over-pax-for-ustar-archives.patch \
27 file://python-libdir.patch \
28 file://py-compile-compile-only-optimized-byte-code.patch \
29 file://buildtest.patch"
30
31SRC_URI[md5sum] = "9199e266993a5bbdc914923349d51e3e"
32SRC_URI[sha256sum] = "4c93abc0bff54b296f41f92dd3aa1e73e554265a6f719df465574983ef6f878c"
33
34do_install_append () {
35 install -d ${D}${datadir}
36
37 # Some distros have both /bin/perl and /usr/bin/perl, but we set perl location
38 # for target as /usr/bin/perl, so fix it to /usr/bin/perl.
39 for i in aclocal aclocal-${NAMEVER} automake automake-${NAMEVER}; do
40 if [ -f ${D}${bindir}/$i ]; then
41 sed -i -e '1s,#!.*perl,#! ${USRBINPATH}/perl,' \
42 -e 's,exec .*/bin/perl \(.*\) exec .*/bin/perl \(.*\),exec ${USRBINPATH}/perl \1 exec ${USRBINPATH}/perl \2,' \
43 ${D}${bindir}/$i
44 fi
45 done
46}
47
48BBCLASSEXTEND = "native nativesdk"