summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/automake/automake_1.12.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/automake/automake_1.12.6.bb')
-rw-r--r--meta/recipes-devtools/automake/automake_1.12.6.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/meta/recipes-devtools/automake/automake_1.12.6.bb b/meta/recipes-devtools/automake/automake_1.12.6.bb
new file mode 100644
index 0000000000..549051bc7b
--- /dev/null
+++ b/meta/recipes-devtools/automake/automake_1.12.6.bb
@@ -0,0 +1,48 @@
1require automake.inc
2LICENSE="GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
4DEPENDS_class-native = "autoconf-native"
5
6RDEPENDS_${PN} += "\
7 autoconf \
8 perl \
9 perl-module-bytes \
10 perl-module-data-dumper \
11 perl-module-strict \
12 perl-module-text-parsewords \
13 perl-module-thread-queue \
14 perl-module-threads \
15 perl-module-vars "
16
17RDEPENDS_${PN}_class-native = "autoconf-native perl-native-runtime"
18
19PATHFIXPATCH = "file://path_prog_fixes.patch"
20PATHFIXPATCH_class-native = ""
21PATHFIXPATCH_class-nativesdk = ""
22
23SRC_URI += "${PATHFIXPATCH} \
24 file://prefer-cpio-over-pax-for-ustar-archives.patch \
25 file://python-libdir.patch \
26 file://py-compile-compile-only-optimized-byte-code.patch \
27 file://buildtest.patch"
28
29SRC_URI[md5sum] = "199d39ece2e6070d64ac20d45ac86026"
30SRC_URI[sha256sum] = "0cbe570db487908e70af7119da85ba04f7e28656b26f717df0265ae08defd9ef"
31
32PR = "r0"
33
34do_install_append () {
35 install -d ${D}${datadir}
36
37 # Some distros have both /bin/perl and /usr/bin/perl, but we set perl location
38 # for target as /usr/bin/perl, so fix it to /usr/bin/perl.
39 for i in aclocal aclocal-1.12 automake automake-1.12; do
40 if [ -f ${D}${bindir}/$i ]; then
41 sed -i -e '1s,#!.*perl,#! ${USRBINPATH}/perl,' \
42 -e 's,exec .*/bin/perl \(.*\) exec .*/bin/perl \(.*\),exec ${USRBINPATH}/perl \1 exec ${USRBINPATH}/perl \2,' \
43 ${D}${bindir}/$i
44 fi
45 done
46}
47
48BBCLASSEXTEND = "native nativesdk"