summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/automake/automake_1.11.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/automake/automake_1.11.1.bb')
-rw-r--r--meta/recipes-devtools/automake/automake_1.11.1.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta/recipes-devtools/automake/automake_1.11.1.bb b/meta/recipes-devtools/automake/automake_1.11.1.bb
new file mode 100644
index 0000000000..a78b6901f1
--- /dev/null
+++ b/meta/recipes-devtools/automake/automake_1.11.1.bb
@@ -0,0 +1,41 @@
1require automake.inc
2
3DEPENDS_virtclass-native = "autoconf-native"
4
5RDEPENDS_automake += "\
6 autoconf \
7 perl \
8 perl-module-bytes \
9 perl-module-constant \
10 perl-module-cwd \
11 perl-module-data-dumper \
12 perl-module-dynaloader \
13 perl-module-errno \
14 perl-module-exporter-heavy \
15 perl-module-file-basename \
16 perl-module-file-compare \
17 perl-module-file-copy \
18 perl-module-file-glob \
19 perl-module-file-spec-unix \
20 perl-module-file-stat \
21 perl-module-getopt-long \
22 perl-module-io \
23 perl-module-io-file \
24 perl-module-posix \
25 perl-module-strict \
26 perl-module-text-parsewords \
27 perl-module-vars "
28
29RDEPENDS_automake-native = "autoconf-native perl-native-runtime"
30
31PATHFIXPATCH = "file://path_prog_fixes.patch;patch=1"
32PATHFIXPATCH_virtclass-native = ""
33
34SRC_URI += "${PATHFIXPATCH}"
35
36do_install () {
37 oe_runmake 'DESTDIR=${D}' install
38 install -d ${D}${datadir}
39}
40
41BBCLASSEXTEND = "native"