summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/autogen/autogen-native_5.18.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/autogen/autogen-native_5.18.3.bb')
-rw-r--r--meta/recipes-devtools/autogen/autogen-native_5.18.3.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-devtools/autogen/autogen-native_5.18.3.bb b/meta/recipes-devtools/autogen/autogen-native_5.18.3.bb
new file mode 100644
index 0000000000..abc0a42102
--- /dev/null
+++ b/meta/recipes-devtools/autogen/autogen-native_5.18.3.bb
@@ -0,0 +1,32 @@
1SUMMARY = "Automated text and program generation tool"
2DESCRIPTION = "AutoGen is a tool designed to simplify the creation and\
3 maintenance of programs that contain large amounts of repetitious text.\
4 It is especially valuable in programs that have several blocks of text\
5 that must be kept synchronized."
6HOMEPAGE = "http://www.gnu.org/software/autogen/"
7SECTION = "devel"
8LICENSE = "GPLv3"
9LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
10
11SRC_URI = "${GNU_MIRROR}/autogen/rel${PV}/autogen-${PV}.tar.gz \
12 file://guile.patch \
13 file://increase-timeout-limit.patch \
14 file://mk-tpl-config.sh-force-exit-value-to-be-0-in-subproc.patch"
15
16SRC_URI[md5sum] = "0fb6b003423e004d94e0119c2390078f"
17SRC_URI[sha256sum] = "73d05a689105eb9b8be54f32498c99ddbd360776fc61cf45be6a2a4eb4a40039"
18
19DEPENDS = "guile-native libtool-native libxml2-native"
20
21inherit autotools texinfo native pkgconfig
22
23# autogen-native links against libguile which may have been relocated with sstate
24# these environment variables ensure there isn't a relocation issue
25export GUILE_LOAD_PATH = "${STAGING_DATADIR_NATIVE}/guile/2.0"
26export GUILE_LOAD_COMPILED_PATH = "${STAGING_LIBDIR_NATIVE}/guile/2.0/ccache"
27
28do_install_append () {
29 create_wrapper ${D}/${bindir}/autogen \
30 GUILE_LOAD_PATH=${STAGING_DATADIR_NATIVE}/guile/2.0 \
31 GUILE_LOAD_COMPILED_PATH=${STAGING_LIBDIR_NATIVE}/guile/2.0/ccache
32}