summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/autogen/autogen-native_5.18.12.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/autogen/autogen-native_5.18.12.bb')
-rw-r--r--meta/recipes-devtools/autogen/autogen-native_5.18.12.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-devtools/autogen/autogen-native_5.18.12.bb b/meta/recipes-devtools/autogen/autogen-native_5.18.12.bb
new file mode 100644
index 0000000000..cf1744c8c0
--- /dev/null
+++ b/meta/recipes-devtools/autogen/autogen-native_5.18.12.bb
@@ -0,0 +1,36 @@
1SUMMARY = "Automated text and program generation tool"
2DESCRIPTION = "AutoGen is a tool designed to simplify the creation and\
3 maintenance of programs that contain large amounts of repetitious text.\
4 It is especially valuable in programs that have several blocks of text\
5 that must be kept synchronized."
6HOMEPAGE = "http://www.gnu.org/software/autogen/"
7SECTION = "devel"
8LICENSE = "GPLv3"
9LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
10
11SRC_URI = "${GNU_MIRROR}/autogen/rel${PV}/autogen-${PV}.tar.gz \
12 file://increase-timeout-limit.patch \
13 file://mk-tpl-config.sh-force-exit-value-to-be-0-in-subproc.patch \
14 file://fix-script-err-when-processing-libguile.patch \
15"
16
17SRC_URI[md5sum] = "551d15ccbf5b5fc5658da375d5003389"
18SRC_URI[sha256sum] = "805c20182f3cb0ebf1571d3b01972851c56fb34348dfdc38799fd0ec3b2badbe"
19
20UPSTREAM_CHECK_URI = "http://ftp.gnu.org/gnu/autogen/"
21UPSTREAM_CHECK_REGEX = "rel(?P<pver>\d+(\.\d+)+)/"
22
23DEPENDS = "guile-native libtool-native libxml2-native"
24
25inherit autotools texinfo native pkgconfig
26
27# autogen-native links against libguile which may have been relocated with sstate
28# these environment variables ensure there isn't a relocation issue
29export GUILE_LOAD_PATH = "${STAGING_DATADIR_NATIVE}/guile/2.0"
30export GUILE_LOAD_COMPILED_PATH = "${STAGING_LIBDIR_NATIVE}/guile/2.0/ccache"
31
32do_install_append () {
33 create_wrapper ${D}/${bindir}/autogen \
34 GUILE_LOAD_PATH=${STAGING_DATADIR_NATIVE}/guile/2.0 \
35 GUILE_LOAD_COMPILED_PATH=${STAGING_LIBDIR_NATIVE}/guile/2.0/ccache
36}