summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/autogen/autogen-native_5.17.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/autogen/autogen-native_5.17.4.bb')
-rw-r--r--meta/recipes-devtools/autogen/autogen-native_5.17.4.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-devtools/autogen/autogen-native_5.17.4.bb b/meta/recipes-devtools/autogen/autogen-native_5.17.4.bb
new file mode 100644
index 0000000000..230c3a798c
--- /dev/null
+++ b/meta/recipes-devtools/autogen/autogen-native_5.17.4.bb
@@ -0,0 +1,35 @@
1SUMMARY = "AutoGen is a tool to manage programs that contain large amounts of repetitious text."
2DESCRIPTION = "AutoGen is a tool designed to simplify the creation and\
3 maintenance of programs that contain large amounts of repetitious text.\
4 It is especially valuable in programs that have several blocks of text\
5 that must be kept synchronized."
6HOMEPAGE = "http://www.gnu.org/software/autogen/"
7SECTION = "devel"
8LICENSE = "GPLv3"
9LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
10
11SRC_URI = "${GNU_MIRROR}/autogen/rel${PV}/autogen-${PV}.tar.gz \
12 file://guile.patch \
13 file://increase-timeout-limit.patch"
14
15SRC_URI[md5sum] = "09f074cba57610bf4ef1147e01c8ae90"
16SRC_URI[sha256sum] = "cd2585f4794d0e9d7f2cb0b9af4f2bd429946e718473edf1cf8c49f081ca71ed"
17
18DEPENDS = "guile-native libtool-native libxml2-native"
19RDEPENDS = "automake pkgconfig"
20
21inherit autotools native
22
23# Following line will be needed for the non-native target recipe.
24#CFLAGS += "-L${STAGING_LIBDIR} -lguile-2.0 -lgc -pthread -I${STAGING_INCDIR}/guile/2.0 -I${STAGING_INCDIR}"
25
26# autogen-native links against libguile which may have been relocated with sstate
27# these environment variables ensure there isn't a relocation issue
28export GUILE_LOAD_PATH = "${STAGING_DATADIR_NATIVE}/guile/2.0"
29export GUILE_LOAD_COMPILED_PATH = "${STAGING_LIBDIR_NATIVE}/guile/2.0/ccache"
30
31do_install_append () {
32 create_wrapper ${D}/${bindir}/autogen \
33 GUILE_LOAD_PATH=${STAGING_DATADIR_NATIVE}/guile/2.0 \
34 GUILE_LOAD_COMPILED_PATH=${STAGING_LIBDIR_NATIVE}/guile/2.0/ccache
35}