summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/autogen/autogen-native_5.12.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/autogen/autogen-native_5.12.bb')
-rw-r--r--meta/recipes-devtools/autogen/autogen-native_5.12.bb13
1 files changed, 12 insertions, 1 deletions
diff --git a/meta/recipes-devtools/autogen/autogen-native_5.12.bb b/meta/recipes-devtools/autogen/autogen-native_5.12.bb
index cdf1ea9b19..eb3721d087 100644
--- a/meta/recipes-devtools/autogen/autogen-native_5.12.bb
+++ b/meta/recipes-devtools/autogen/autogen-native_5.12.bb
@@ -13,7 +13,7 @@ SRC_URI = "${GNU_MIRROR}/autogen/rel${PV}/autogen-${PV}.tar.gz"
13SRC_URI[md5sum] = "6c6671b76021fb30dd43b0d5fdb7180b" 13SRC_URI[md5sum] = "6c6671b76021fb30dd43b0d5fdb7180b"
14SRC_URI[sha256sum] = "37e885d6c8a58f33ab198d38bb972fa4c14236f951d628161dde6e20527d0df2" 14SRC_URI[sha256sum] = "37e885d6c8a58f33ab198d38bb972fa4c14236f951d628161dde6e20527d0df2"
15 15
16PR = "r1" 16PR = "r2"
17 17
18DEPENDS = "guile-native libtool-native libxml2-native" 18DEPENDS = "guile-native libtool-native libxml2-native"
19RDEPENDS = "automake pkgconfig" 19RDEPENDS = "automake pkgconfig"
@@ -22,3 +22,14 @@ inherit autotools native
22 22
23# Following line will be needed for the non-native target recipe. 23# Following line will be needed for the non-native target recipe.
24#CFLAGS += "-L${STAGING_LIBDIR} -lguile-2.0 -lgc -pthread -I${STAGING_INCDIR}/guile/2.0 -I${STAGING_INCDIR}" 24#CFLAGS += "-L${STAGING_LIBDIR} -lguile-2.0 -lgc -pthread -I${STAGING_INCDIR}/guile/2.0 -I${STAGING_INCDIR}"
25
26# autogen-native links against libguile which may have been relocated with sstate
27# these environment variables ensure there isn't a relocation issue
28export GUILE_LOAD_PATH = "${STAGING_DATADIR_NATIVE}/guile/2.0"
29export GUILE_LOAD_COMPILED_PATH = "${STAGING_LIBDIR_NATIVE}/guile/2.0/ccache"
30
31do_install_append () {
32 create_wrapper ${D}/${bindir}/autogen \
33 GUILE_LOAD_PATH=${STAGING_DATADIR_NATIVE}/guile/2.0 \
34 GUILE_LOAD_COMPILED_PATH=${STAGING_LIBDIR_NATIVE}/guile/2.0/ccache
35}