summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/util-linux/util-linux_2.21.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/util-linux/util-linux_2.21.bb')
-rw-r--r--meta/recipes-core/util-linux/util-linux_2.21.bb10
1 files changed, 4 insertions, 6 deletions
diff --git a/meta/recipes-core/util-linux/util-linux_2.21.bb b/meta/recipes-core/util-linux/util-linux_2.21.bb
index ab26fcd99a..c0c8bc6edd 100644
--- a/meta/recipes-core/util-linux/util-linux_2.21.bb
+++ b/meta/recipes-core/util-linux/util-linux_2.21.bb
@@ -3,7 +3,7 @@ PR = "r5"
3require util-linux.inc 3require util-linux.inc
4 4
5# note that `lscpu' is under GPLv3+ 5# note that `lscpu' is under GPLv3+
6LICENSE_util-linux-lscpu = "GPLv3+" 6LICENSE_${PN}-lscpu = "GPLv3+"
7 7
8SRC_URI += "file://util-linux-ng-replace-siginterrupt.patch \ 8SRC_URI += "file://util-linux-ng-replace-siginterrupt.patch \
9 file://util-linux-ng-2.16-mount_lock_path.patch \ 9 file://util-linux-ng-2.16-mount_lock_path.patch \
@@ -16,16 +16,14 @@ SRC_URI[sha256sum] = "2813ae6fe0449b60402e122c2baf97f26aa53e6e2dd05591c6cbcdf67f
16 16
17# Only lscpu part is gplv3; rest of the code is not, 17# Only lscpu part is gplv3; rest of the code is not,
18# so take out the lscpu parts while running non-gplv3 build. 18# so take out the lscpu parts while running non-gplv3 build.
19# The removal of the package should now occur during
20# the build if INCOMPATIBLE_LICENSE is set to GPLv3
21
19python () { 22python () {
20 d.setVar("REMOVELSCPU", "no") 23 d.setVar("REMOVELSCPU", "no")
21 if (d.getVar("INCOMPATIBLE_LICENSE", True) or "").find("GPLv3") != -1: 24 if (d.getVar("INCOMPATIBLE_LICENSE", True) or "").find("GPLv3") != -1:
22 # avoid GPLv3 25 # avoid GPLv3
23 d.setVar("REMOVELSCPU", "yes") 26 d.setVar("REMOVELSCPU", "yes")
24 packages = (d.getVar("PACKAGES", False) or "").split()
25 if "util-linux-lscpu" in packages:
26 packages.remove("util-linux-lscpu")
27 d.setVar("PACKAGES", " ".join(packages))
28
29 src_uri = (d.getVar("SRC_URI", False) or "").split() 27 src_uri = (d.getVar("SRC_URI", False) or "").split()
30 src_uri.append("file://remove-lscpu.patch") 28 src_uri.append("file://remove-lscpu.patch")
31 d.setVar("SRC_URI", " ".join(src_uri)) 29 d.setVar("SRC_URI", " ".join(src_uri))