summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/util-linux/util-linux_2.21.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/util-linux/util-linux_2.21.1.bb')
-rw-r--r--meta/recipes-core/util-linux/util-linux_2.21.1.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-core/util-linux/util-linux_2.21.1.bb b/meta/recipes-core/util-linux/util-linux_2.21.1.bb
new file mode 100644
index 0000000000..12faba00bd
--- /dev/null
+++ b/meta/recipes-core/util-linux/util-linux_2.21.1.bb
@@ -0,0 +1,46 @@
1MAJOR_VERSION = "2.21"
2PR = "r0"
3require util-linux.inc
4
5# note that `lscpu' is under GPLv3+
6LICENSE_${PN}-lscpu = "GPLv3+"
7
8SRC_URI += "file://util-linux-ng-replace-siginterrupt.patch \
9 file://util-linux-ng-2.16-mount_lock_path.patch \
10 file://uclibc-__progname-conflict.patch \
11 file://fix_NL_TIME_FIRST_WEEKDAY.patch \
12"
13
14SRC_URI[md5sum] = "3d9ad37bf8c5a8e6d0e165b020cf9ba5"
15SRC_URI[sha256sum] = "4bf9641fd58454106589be8a8d1cfd61e7694f0a6912d8095d17b1fb94b85abe"
16
17# Only lscpu part is gplv3; rest of the code is not,
18# so take out the lscpu parts while running non-gplv3 build.
19# The removal of the package should now occur during
20# the build if INCOMPATIBLE_LICENSE is set to GPLv3
21
22python () {
23 d.setVar("REMOVELSCPU", "no")
24 if (d.getVar("INCOMPATIBLE_LICENSE", True) or "").find("GPLv3") != -1:
25 # avoid GPLv3
26 d.setVar("REMOVELSCPU", "yes")
27 src_uri = (d.getVar("SRC_URI", False) or "").split()
28 src_uri.append("file://remove-lscpu.patch")
29 d.setVar("SRC_URI", " ".join(src_uri))
30}
31
32do_remove_lscpu() {
33 if [ "x${REMOVELSCPU}" = "xyes" ]; then
34 rm -f sys-utils/lscpu.c sys-utils/lscpu.1
35 rm -rf tests/ts/lscpu tests/expected/lscpu
36 fi
37}
38
39addtask remove_lscpu before do_configure after do_patch
40
41CACHED_CONFIGUREVARS += "scanf_cv_alloc_modifier=as"
42EXTRA_OECONF_virtclass-native += "--disable-fallocate --disable-use-tty-group"
43
44do_install_append () {
45 sed -i -e '1s,.*,#!${bindir}/env perl,' ${D}${bindir}/chkdupexe
46}