summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/tasks/task-core-tools.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/tasks/task-core-tools.bb')
-rw-r--r--meta/recipes-core/tasks/task-core-tools.bb102
1 files changed, 0 insertions, 102 deletions
diff --git a/meta/recipes-core/tasks/task-core-tools.bb b/meta/recipes-core/tasks/task-core-tools.bb
deleted file mode 100644
index 1a42f15bdc..0000000000
--- a/meta/recipes-core/tasks/task-core-tools.bb
+++ /dev/null
@@ -1,102 +0,0 @@
1#
2# Copyright (C) 2008 OpenedHand Ltd.
3#
4
5DESCRIPTION = "Tools tasks for OE-Core"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
8 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
9PR = "r15"
10
11PACKAGES = "\
12 task-core-tools-debug \
13 task-core-tools-debug-dbg \
14 task-core-tools-debug-dev \
15 task-core-tools-profile \
16 task-core-tools-profile-dbg \
17 task-core-tools-profile-dev \
18 task-core-tools-testapps \
19 task-core-tools-testapps-dbg \
20 task-core-tools-testapps-dev \
21 "
22
23PACKAGE_ARCH = "${MACHINE_ARCH}"
24
25ALLOW_EMPTY = "1"
26
27# kexec-tools doesn't work on Mips
28KEXECTOOLS ?= "kexec"
29KEXECTOOLS_mips ?= ""
30KEXECTOOLS_mipsel ?= ""
31KEXECTOOLS_powerpc ?= ""
32
33RDEPENDS_task-core-tools-debug = "\
34 gdb \
35 gdbserver \
36 tcf-agent \
37 rsync \
38 strace"
39
40RDEPENDS_task-core-tools-profile = "\
41 oprofile \
42 oprofileui-server \
43 powertop \
44 latencytop \
45 lttng-control \
46 lttng-viewer"
47
48RRECOMMENDS_task-core-tools-profile = "\
49 perf \
50 trace-cmd \
51 kernel-module-oprofile \
52 blktrace \
53 sysprof \
54 "
55
56# systemtap needs elfutils which is not fully buildable on uclibc
57# hence we exclude it from uclibc based builds
58SYSTEMTAP = "systemtap"
59SYSTEMTAP_libc-uclibc = ""
60
61# lttng-ust uses sched_getcpu() which is not there on uclibc
62# for some of the architectures it can be patched to call the
63# syscall directly but for x86_64 __NR_getcpu is a vsyscall
64# which means we can not use syscall() to call it. So we ignore
65# it for x86_64/uclibc
66
67LTTNGUST = "lttng-ust"
68LTTNGUST_libc-uclibc = ""
69
70# exmap-console
71# exmap-server
72
73# At present we only build lttng-ust on
74# qemux86/qemux86-64/qemuppc/qemuarm/emenlow/atom-pc since upstream liburcu
75# (which is required by lttng-ust) may not build on other platforms, like
76# MIPS.
77RDEPENDS_task-core-tools-profile_append_qemux86 = " valgrind lttng-ust ${SYSTEMTAP}"
78RDEPENDS_task-core-tools-profile_append_qemux86-64 = " ${LTTNGUST} ${SYSTEMTAP}"
79RDEPENDS_task-core-tools-profile_append_qemuppc = " ${LTTNGUST} ${SYSTEMTAP}"
80RDEPENDS_task-core-tools-profile_append_qemuarm = " ${LTTNGUST} ${SYSTEMTAP}"
81
82RDEPENDS_task-core-tools-testapps = "\
83 blktool \
84 fstests \
85 tslib-calibrate \
86 tslib-tests \
87 lrzsz \
88 ${KEXECTOOLS} \
89 alsa-utils-amixer \
90 alsa-utils-aplay \
91 owl-video \
92 gst-meta-video \
93 gst-meta-audio \
94 mesa-demos \
95 x11perf \
96 xrestop \
97 xwininfo \
98 xprop \
99 xvideo-tests \
100 clutter-box2d \
101 ltp \
102 "