summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/tasks/task-core-tools-profile.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/tasks/task-core-tools-profile.bb')
-rw-r--r--meta/recipes-core/tasks/task-core-tools-profile.bb69
1 files changed, 69 insertions, 0 deletions
diff --git a/meta/recipes-core/tasks/task-core-tools-profile.bb b/meta/recipes-core/tasks/task-core-tools-profile.bb
new file mode 100644
index 0000000000..254d3f5e48
--- /dev/null
+++ b/meta/recipes-core/tasks/task-core-tools-profile.bb
@@ -0,0 +1,69 @@
1#
2# Copyright (C) 2008 OpenedHand Ltd.
3#
4
5DESCRIPTION = "Profile tools tasks for OE-Core"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
8 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
9
10PACKAGES = "\
11 ${PN} \
12 ${PN}-dbg \
13 ${PN}-dev \
14 "
15
16PACKAGE_ARCH = "${MACHINE_ARCH}"
17
18ALLOW_EMPTY = "1"
19
20RRECOMMENDS_${PN} = "\
21 perf \
22 trace-cmd \
23 kernel-module-oprofile \
24 blktrace \
25 sysprof \
26 "
27
28PROFILETOOLS = "\
29 oprofile \
30 oprofileui-server \
31 powertop \
32 latencytop \
33 lttng-control \
34 lttng-viewer"
35
36# systemtap needs elfutils which is not fully buildable on uclibc
37# hence we exclude it from uclibc based builds
38SYSTEMTAP = "systemtap"
39SYSTEMTAP_libc-uclibc = ""
40
41# lttng-ust uses sched_getcpu() which is not there on uclibc
42# for some of the architectures it can be patched to call the
43# syscall directly but for x86_64 __NR_getcpu is a vsyscall
44# which means we can not use syscall() to call it. So we ignore
45# it for x86_64/uclibc
46
47LTTNGUST = "lttng-ust"
48LTTNGUST_libc-uclibc = ""
49LTTNGUST_mips = ""
50
51# valgrind does not work on mips
52
53VALGRIND = "valgrind"
54VALGRIND_libc-uclibc = ""
55VALGRIND_mips = ""
56
57# exmap-console
58# exmap-server
59
60# At present we only build lttng-ust on
61# qemux86/qemux86-64/qemuppc/qemuarm/emenlow/atom-pc since upstream liburcu
62# (which is required by lttng-ust) may not build on other platforms, like
63# MIPS.
64RDEPENDS_${PN} = "\
65 ${PROFILETOOLS} \
66 ${LTTNGUST} \
67 ${SYSTEMTAP} \
68 ${VALGRIND} \
69 "