summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/tasks/task-core-sdk.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/tasks/task-core-sdk.bb')
-rw-r--r--meta/recipes-core/tasks/task-core-sdk.bb89
1 files changed, 89 insertions, 0 deletions
diff --git a/meta/recipes-core/tasks/task-core-sdk.bb b/meta/recipes-core/tasks/task-core-sdk.bb
new file mode 100644
index 0000000000..a158509b2d
--- /dev/null
+++ b/meta/recipes-core/tasks/task-core-sdk.bb
@@ -0,0 +1,89 @@
1#
2# Copyright (C) 2007 OpenedHand Ltd.
3#
4
5DESCRIPTION = "Software Development Tasks for OpenedHand Poky"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
8 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
9DEPENDS = "task-poky"
10PR = "r7"
11
12ALLOW_EMPTY = "1"
13#PACKAGEFUNCS =+ 'generate_sdk_pkgs'
14
15PACKAGES = "\
16 task-core-sdk \
17 task-core-sdk-dbg \
18 task-core-sdk-dev"
19
20RDEPENDS_task-core-sdk = "\
21 autoconf \
22 automake \
23 binutils \
24 binutils-symlinks \
25 coreutils \
26 cpp \
27 cpp-symlinks \
28 diffutils \
29 gcc \
30 gcc-symlinks \
31 g++ \
32 g++-symlinks \
33 gettext \
34 make \
35 intltool \
36 libstdc++ \
37 libstdc++-dev \
38 libtool \
39 perl-module-re \
40 perl-module-text-wrap \
41 pkgconfig \
42 findutils \
43 quilt \
44 less \
45 distcc \
46 ldd \
47 file \
48 tcl"
49
50#python generate_sdk_pkgs () {
51# poky_pkgs = read_pkgdata('task-poky', d)['PACKAGES']
52# pkgs = bb.data.getVar('PACKAGES', d, 1).split()
53# for pkg in poky_pkgs.split():
54# newpkg = pkg.replace('task-poky', 'task-core-sdk')
55#
56# # for each of the task packages, add a corresponding sdk task
57# pkgs.append(newpkg)
58#
59# # for each sdk task, take the rdepends of the non-sdk task, and turn
60# # that into rrecommends upon the -dev versions of those, not unlike
61# # the package depchain code
62# spkgdata = read_subpkgdata(pkg, d)
63#
64# rdepends = explode_deps(spkgdata.get('RDEPENDS_%s' % pkg) or '')
65# rreclist = []
66#
67# for depend in rdepends:
68# split_depend = depend.split(' (')
69# name = split_depend[0].strip()
70# if packaged('%s-dev' % name, d):
71# rreclist.append('%s-dev' % name)
72# else:
73# deppkgdata = read_subpkgdata(name, d)
74# rdepends2 = explode_deps(deppkgdata.get('RDEPENDS_%s' % name) or '')
75# for depend in rdepends2:
76# split_depend = depend.split(' (')
77# name = split_depend[0].strip()
78# if packaged('%s-dev' % name, d):
79# rreclist.append('%s-dev' % name)
80#
81# oldrrec = bb.data.getVar('RRECOMMENDS_%s' % newpkg, d) or ''
82# bb.data.setVar('RRECOMMENDS_%s' % newpkg, oldrrec + ' ' + ' '.join(rreclist), d)
83# # bb.note('RRECOMMENDS_%s = "%s"' % (newpkg, bb.data.getVar('RRECOMMENDS_%s' % newpkg, d)))
84#
85# # bb.note('pkgs is %s' % pkgs)
86# bb.data.setVar('PACKAGES', ' '.join(pkgs), d)
87#}
88#
89#PACKAGES_DYNAMIC = "task-core-sdk-*"