summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/tasks/task-base.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/tasks/task-base.bb')
-rw-r--r--meta/recipes-core/tasks/task-base.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-core/tasks/task-base.bb b/meta/recipes-core/tasks/task-base.bb
index 2032432844..ddae7aebee 100644
--- a/meta/recipes-core/tasks/task-base.bb
+++ b/meta/recipes-core/tasks/task-base.bb
@@ -126,8 +126,8 @@ python __anonymous () {
126 126
127 import bb 127 import bb
128 128
129 distro_features = set(d.getVar("DISTRO_FEATURES", 1).split()) 129 distro_features = set(d.getVar("DISTRO_FEATURES", True).split())
130 machine_features= set(d.getVar("MACHINE_FEATURES", 1).split()) 130 machine_features= set(d.getVar("MACHINE_FEATURES", True).split())
131 131
132 if "bluetooth" in distro_features and not "bluetooth" in machine_features and ("pcmcia" in machine_features or "pci" in machine_features or "usbhost" in machine_features): 132 if "bluetooth" in distro_features and not "bluetooth" in machine_features and ("pcmcia" in machine_features or "pci" in machine_features or "usbhost" in machine_features):
133 d.setVar("ADD_BT", "task-base-bluetooth") 133 d.setVar("ADD_BT", "task-base-bluetooth")