summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/systemd/systemd_239.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/systemd/systemd_239.bb')
-rw-r--r--meta/recipes-core/systemd/systemd_239.bb28
1 files changed, 9 insertions, 19 deletions
diff --git a/meta/recipes-core/systemd/systemd_239.bb b/meta/recipes-core/systemd/systemd_239.bb
index 7ed932141d..bc16407e09 100644
--- a/meta/recipes-core/systemd/systemd_239.bb
+++ b/meta/recipes-core/systemd/systemd_239.bb
@@ -31,7 +31,6 @@ SRC_URI += "file://touchscreen.rules \
31 file://0022-build-sys-Detect-whether-struct-statx-is-defined-in-.patch \ 31 file://0022-build-sys-Detect-whether-struct-statx-is-defined-in-.patch \
32 file://0023-resolvconf-fixes-for-the-compatibility-interface.patch \ 32 file://0023-resolvconf-fixes-for-the-compatibility-interface.patch \
33 " 33 "
34SRC_URI_append_qemuall = " file://0001-core-device.c-Change-the-default-device-timeout-to-2.patch"
35 34
36# patches made for musl are only applied on TCLIBC is musl 35# patches made for musl are only applied on TCLIBC is musl
37SRC_URI += "${SRC_URI_MUSL}" 36SRC_URI += "${SRC_URI_MUSL}"
@@ -218,10 +217,6 @@ do_install() {
218 [ ! -e ${D}/init ] && ln -s ${rootlibexecdir}/systemd/systemd ${D}/init 217 [ ! -e ${D}/init ] && ln -s ${rootlibexecdir}/systemd/systemd ${D}/init
219 [ ! -e ${D}/${base_sbindir}/udevd ] && ln -s ${rootlibexecdir}/systemd/systemd-udevd ${D}/${base_sbindir}/udevd 218 [ ! -e ${D}/${base_sbindir}/udevd ] && ln -s ${rootlibexecdir}/systemd/systemd-udevd ${D}/${base_sbindir}/udevd
220 219
221 # Create machine-id
222 # 20:12 < mezcalero> koen: you have three options: a) run systemd-machine-id-setup at install time, b) have / read-only and an empty file there (for stateless) and c) boot with / writable
223 touch ${D}${sysconfdir}/machine-id
224
225 install -d ${D}${sysconfdir}/udev/rules.d/ 220 install -d ${D}${sysconfdir}/udev/rules.d/
226 install -d ${D}${sysconfdir}/tmpfiles.d 221 install -d ${D}${sysconfdir}/tmpfiles.d
227 install -m 0644 ${WORKDIR}/*.rules ${D}${sysconfdir}/udev/rules.d/ 222 install -m 0644 ${WORKDIR}/*.rules ${D}${sysconfdir}/udev/rules.d/
@@ -256,11 +251,6 @@ do_install() {
256 ln -sf ../systemd-update-utmp-runlevel.service ${D}${systemd_unitdir}/system/rescue.target.wants/systemd-update-utmp-runlevel.service 251 ln -sf ../systemd-update-utmp-runlevel.service ${D}${systemd_unitdir}/system/rescue.target.wants/systemd-update-utmp-runlevel.service
257 fi 252 fi
258 253
259 # Enable journal to forward message to syslog daemon
260 sed -i -e 's/.*ForwardToSyslog.*/ForwardToSyslog=yes/' ${D}${sysconfdir}/systemd/journald.conf
261 # Set the maximium size of runtime journal to 64M as default
262 sed -i -e 's/.*RuntimeMaxUse.*/RuntimeMaxUse=64M/' ${D}${sysconfdir}/systemd/journald.conf
263
264 # this file is needed to exist if networkd is disabled but timesyncd is still in use since timesyncd checks it 254 # this file is needed to exist if networkd is disabled but timesyncd is still in use since timesyncd checks it
265 # for existence else it fails 255 # for existence else it fails
266 if [ -s ${D}${exec_prefix}/lib/tmpfiles.d/systemd.conf ]; then 256 if [ -s ${D}${exec_prefix}/lib/tmpfiles.d/systemd.conf ]; then
@@ -284,6 +274,14 @@ do_install() {
284 chown polkitd:root ${D}${datadir}/polkit-1/rules.d 274 chown polkitd:root ${D}${datadir}/polkit-1/rules.d
285 fi 275 fi
286 fi 276 fi
277
278 # conf files are handled by systemd-conf
279 rm -f ${D}${sysconfdir}/machine-id
280 rm -f ${D}${sysconfdir}/systemd/coredump.conf
281 rm -f ${D}${sysconfdir}/systemd/journald.conf
282 rm -f ${D}${sysconfdir}/systemd/logind.conf
283 rm -f ${D}${sysconfdir}/systemd/system.conf
284 rm -f ${D}${sysconfdir}/systemd/user.conf
287} 285}
288 286
289 287
@@ -433,13 +431,6 @@ FILES_${PN}-extra-utils = "\
433 ${rootlibexecdir}/systemd/systemd-cgroups-agent \ 431 ${rootlibexecdir}/systemd/systemd-cgroups-agent \
434" 432"
435 433
436CONFFILES_${PN} = "${sysconfdir}/machine-id \
437 ${sysconfdir}/systemd/coredump.conf \
438 ${sysconfdir}/systemd/journald.conf \
439 ${sysconfdir}/systemd/logind.conf \
440 ${sysconfdir}/systemd/system.conf \
441 ${sysconfdir}/systemd/user.conf"
442
443FILES_${PN} = " ${base_bindir}/* \ 434FILES_${PN} = " ${base_bindir}/* \
444 ${base_sbindir}/shutdown \ 435 ${base_sbindir}/shutdown \
445 ${base_sbindir}/halt \ 436 ${base_sbindir}/halt \
@@ -455,7 +446,6 @@ FILES_${PN} = " ${base_bindir}/* \
455 ${datadir}/${BPN} \ 446 ${datadir}/${BPN} \
456 ${datadir}/factory \ 447 ${datadir}/factory \
457 ${sysconfdir}/dbus-1/ \ 448 ${sysconfdir}/dbus-1/ \
458 ${sysconfdir}/machine-id \
459 ${sysconfdir}/modules-load.d/ \ 449 ${sysconfdir}/modules-load.d/ \
460 ${sysconfdir}/pam.d/ \ 450 ${sysconfdir}/pam.d/ \
461 ${sysconfdir}/sysctl.d/ \ 451 ${sysconfdir}/sysctl.d/ \
@@ -504,7 +494,7 @@ FILES_${PN}-dev += "${base_libdir}/security/*.la ${datadir}/dbus-1/interfaces/ $
504 494
505RDEPENDS_${PN} += "kmod dbus util-linux-mount udev (= ${EXTENDPKGV}) util-linux-agetty util-linux-fsck" 495RDEPENDS_${PN} += "kmod dbus util-linux-mount udev (= ${EXTENDPKGV}) util-linux-agetty util-linux-fsck"
506RDEPENDS_${PN} += "${@bb.utils.contains('PACKAGECONFIG', 'serial-getty-generator', '', 'systemd-serialgetty', d)}" 496RDEPENDS_${PN} += "${@bb.utils.contains('PACKAGECONFIG', 'serial-getty-generator', '', 'systemd-serialgetty', d)}"
507RDEPENDS_${PN} += "volatile-binds update-rc.d" 497RDEPENDS_${PN} += "volatile-binds update-rc.d systemd-conf"
508 498
509RRECOMMENDS_${PN} += "systemd-extra-utils \ 499RRECOMMENDS_${PN} += "systemd-extra-utils \
510 systemd-compat-units udev-hwdb \ 500 systemd-compat-units udev-hwdb \