summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/systemd/systemd_234.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/systemd/systemd_234.bb')
-rw-r--r--meta/recipes-core/systemd/systemd_234.bb28
1 files changed, 21 insertions, 7 deletions
diff --git a/meta/recipes-core/systemd/systemd_234.bb b/meta/recipes-core/systemd/systemd_234.bb
index 971226ff7c..bcb683f10a 100644
--- a/meta/recipes-core/systemd/systemd_234.bb
+++ b/meta/recipes-core/systemd/systemd_234.bb
@@ -10,7 +10,7 @@ SECTION = "base/shell"
10 10
11inherit useradd pkgconfig autotools perlnative update-rc.d update-alternatives qemu systemd ptest gettext bash-completion manpages 11inherit useradd pkgconfig autotools perlnative update-rc.d update-alternatives qemu systemd ptest gettext bash-completion manpages
12 12
13SRC_URI += " \ 13SRC_URI = "git://github.com/systemd/systemd.git;protocol=git \
14 file://touchscreen.rules \ 14 file://touchscreen.rules \
15 file://00-create-volatile.conf \ 15 file://00-create-volatile.conf \
16 file://init \ 16 file://init \
@@ -27,6 +27,19 @@ SRC_URI += " \
27 file://0017-remove-duplicate-include-uchar.h.patch \ 27 file://0017-remove-duplicate-include-uchar.h.patch \
28 file://0018-check-for-uchar.h-in-configure.patch \ 28 file://0018-check-for-uchar.h-in-configure.patch \
29 file://0019-socket-util-don-t-fail-if-libc-doesn-t-support-IDN.patch \ 29 file://0019-socket-util-don-t-fail-if-libc-doesn-t-support-IDN.patch \
30 file://0001-add-fallback-parse_printf_format-implementation.patch \
31 file://0002-src-basic-missing.h-check-for-missing-strndupa.patch \
32 file://0003-don-t-fail-if-GLOB_BRACE-and-GLOB_ALTDIRFUNC-is-not-.patch \
33 file://0004-src-basic-missing.h-check-for-missing-__compar_fn_t-.patch \
34 file://0006-Include-netinet-if_ether.h.patch \
35 file://0007-check-for-missing-canonicalize_file_name.patch \
36 file://0008-Do-not-enable-nss-tests.patch \
37 file://0009-test-hexdecoct.c-Include-missing.h-form-strndupa.patch \
38 file://0010-test-sizeof.c-Disable-tests-for-missing-typedefs-in-.patch \
39 file://0011-don-t-use-glibc-specific-qsort_r.patch \
40 file://0012-don-t-pass-AT_SYMLINK_NOFOLLOW-flag-to-faccessat.patch \
41 file://0013-comparison_fn_t-is-glibc-specific-use-raw-signature-.patch \
42 file://0001-Define-_PATH_WTMPX-and-_PATH_UTMPX-if-not-defined.patch \
30 " 43 "
31SRC_URI_append_qemuall = " file://0001-core-device.c-Change-the-default-device-timeout-to-2.patch" 44SRC_URI_append_qemuall = " file://0001-core-device.c-Change-the-default-device-timeout-to-2.patch"
32 45
@@ -47,7 +60,8 @@ PACKAGECONFIG ??= "xz \
47 vconsole \ 60 vconsole \
48 quotacheck \ 61 quotacheck \
49 hostnamed \ 62 hostnamed \
50 ${@bb.utils.contains('TCLIBC', 'glibc', 'myhostname sysusers', '', d)} \ 63 ${@bb.utils.contains('TCLIBC', 'glibc', 'myhostname sysusers utmp', '', d)} \
64 nss \
51 hibernate \ 65 hibernate \
52 timedated \ 66 timedated \
53 timesyncd \ 67 timesyncd \
@@ -56,13 +70,16 @@ PACKAGECONFIG ??= "xz \
56 smack \ 70 smack \
57 logind \ 71 logind \
58 firstboot \ 72 firstboot \
59 utmp \
60 polkit \ 73 polkit \
61 resolved \ 74 resolved \
62 networkd \ 75 networkd \
63" 76"
64PACKAGECONFIG_remove_libc-musl = "selinux" 77PACKAGECONFIG_remove_libc-musl = "selinux"
65PACKAGECONFIG_remove_libc-musl = "smack" 78PACKAGECONFIG_remove_libc-musl = "smack"
79PACKAGECONFIG_remove_libc-musl = "resolved"
80PACKAGECONFIG_remove_libc-musl = "nss"
81PACKAGECONFIG_remove_libc-musl = "localed"
82PACKAGECONFIG_remove_libc-musl = "ldconfig"
66 83
67# Use the upstream systemd serial-getty@.service and rely on 84# Use the upstream systemd serial-getty@.service and rely on
68# systemd-getty-generator instead of using the OE-core specific 85# systemd-getty-generator instead of using the OE-core specific
@@ -83,6 +100,7 @@ PACKAGECONFIG[vconsole] = "--enable-vconsole,--disable-vconsole,,${PN}-vconsole-
83PACKAGECONFIG[quotacheck] = "--enable-quotacheck,--disable-quotacheck" 100PACKAGECONFIG[quotacheck] = "--enable-quotacheck,--disable-quotacheck"
84PACKAGECONFIG[hostnamed] = "--enable-hostnamed,--disable-hostnamed" 101PACKAGECONFIG[hostnamed] = "--enable-hostnamed,--disable-hostnamed"
85PACKAGECONFIG[myhostname] = "--enable-myhostname,--disable-myhostname" 102PACKAGECONFIG[myhostname] = "--enable-myhostname,--disable-myhostname"
103PACKAGECONFIG[nss] = "--enable-nss-systemd,--disable-nss-systemd"
86PACKAGECONFIG[rfkill] = "--enable-rfkill,--disable-rfkill" 104PACKAGECONFIG[rfkill] = "--enable-rfkill,--disable-rfkill"
87PACKAGECONFIG[hibernate] = "--enable-hibernate,--disable-hibernate" 105PACKAGECONFIG[hibernate] = "--enable-hibernate,--disable-hibernate"
88PACKAGECONFIG[timedated] = "--enable-timedated,--disable-timedated" 106PACKAGECONFIG[timedated] = "--enable-timedated,--disable-timedated"
@@ -612,8 +630,4 @@ pkg_prerm_udev-hwdb () {
612python () { 630python () {
613 if not bb.utils.contains ('DISTRO_FEATURES', 'systemd', True, False, d): 631 if not bb.utils.contains ('DISTRO_FEATURES', 'systemd', True, False, d):
614 raise bb.parse.SkipPackage("'systemd' not in DISTRO_FEATURES") 632 raise bb.parse.SkipPackage("'systemd' not in DISTRO_FEATURES")
615
616 import re
617 if re.match('.*musl*', d.getVar('TARGET_OS')) != None:
618 raise bb.parse.SkipPackage("Not _yet_ supported on musl based targets")
619} 633}