summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/systemd/systemd_234.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/systemd/systemd_234.bb')
-rw-r--r--meta/recipes-core/systemd/systemd_234.bb13
1 files changed, 5 insertions, 8 deletions
diff --git a/meta/recipes-core/systemd/systemd_234.bb b/meta/recipes-core/systemd/systemd_234.bb
index 9a10a31881..4132cdf40f 100644
--- a/meta/recipes-core/systemd/systemd_234.bb
+++ b/meta/recipes-core/systemd/systemd_234.bb
@@ -8,7 +8,11 @@ DEPENDS = "kmod intltool-native gperf-native acl readline libcap libcgroup util-
8 8
9SECTION = "base/shell" 9SECTION = "base/shell"
10 10
11inherit useradd pkgconfig autotools perlnative update-rc.d update-alternatives qemu systemd ptest gettext bash-completion manpages 11inherit useradd pkgconfig autotools perlnative update-rc.d update-alternatives qemu systemd ptest gettext bash-completion manpages distro_features_check
12
13# As this recipe builds udev, respect systemd being in DISTRO_FEATURES so
14# that we don't build both udev and systemd in world builds.
15REQUIRED_DISTRO_FEATURES = "systemd"
12 16
13SRC_URI = "git://github.com/systemd/systemd.git;protocol=git \ 17SRC_URI = "git://github.com/systemd/systemd.git;protocol=git \
14 file://touchscreen.rules \ 18 file://touchscreen.rules \
@@ -630,10 +634,3 @@ pkg_postinst_udev-hwdb () {
630pkg_prerm_udev-hwdb () { 634pkg_prerm_udev-hwdb () {
631 rm -f $D${sysconfdir}/udev/hwdb.bin 635 rm -f $D${sysconfdir}/udev/hwdb.bin
632} 636}
633
634# As this recipe builds udev, respect systemd being in DISTRO_FEATURES so
635# that we don't build both udev and systemd in world builds.
636python () {
637 if not bb.utils.contains ('DISTRO_FEATURES', 'systemd', True, False, d):
638 raise bb.parse.SkipPackage("'systemd' not in DISTRO_FEATURES")
639}