summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/systemd/systemd-serialgetty.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/systemd/systemd-serialgetty.bb')
-rw-r--r--meta/recipes-core/systemd/systemd-serialgetty.bb18
1 files changed, 9 insertions, 9 deletions
diff --git a/meta/recipes-core/systemd/systemd-serialgetty.bb b/meta/recipes-core/systemd/systemd-serialgetty.bb
index 92d35ebcf7..7ca951cdbd 100644
--- a/meta/recipes-core/systemd/systemd-serialgetty.bb
+++ b/meta/recipes-core/systemd/systemd-serialgetty.bb
@@ -19,11 +19,11 @@ REQUIRED_DISTRO_FEATURES = "systemd"
19do_install() { 19do_install() {
20 if [ ! -z "${SERIAL_CONSOLES}" ] ; then 20 if [ ! -z "${SERIAL_CONSOLES}" ] ; then
21 default_baudrate=`echo "${SERIAL_CONSOLES}" | sed 's/\;.*//'` 21 default_baudrate=`echo "${SERIAL_CONSOLES}" | sed 's/\;.*//'`
22 install -d ${D}${systemd_unitdir}/system/ 22 install -d ${D}${systemd_system_unitdir}/
23 install -d ${D}${sysconfdir}/systemd/system/getty.target.wants/ 23 install -d ${D}${sysconfdir}/systemd/system/getty.target.wants/
24 install -m 0644 ${WORKDIR}/serial-getty@.service ${D}${systemd_unitdir}/system/ 24 install -m 0644 ${WORKDIR}/serial-getty@.service ${D}${systemd_system_unitdir}/
25 sed -i -e "s/\@BAUDRATE\@/$default_baudrate/g" ${D}${systemd_unitdir}/system/serial-getty@.service 25 sed -i -e "s/\@BAUDRATE\@/$default_baudrate/g" ${D}${systemd_system_unitdir}/serial-getty@.service
26 sed -i -e "s/\@TERM\@/${SERIAL_TERM}/g" ${D}${systemd_unitdir}/system/serial-getty@.service 26 sed -i -e "s/\@TERM\@/${SERIAL_TERM}/g" ${D}${systemd_system_unitdir}/serial-getty@.service
27 27
28 tmp="${SERIAL_CONSOLES}" 28 tmp="${SERIAL_CONSOLES}"
29 for entry in $tmp ; do 29 for entry in $tmp ; do
@@ -31,14 +31,14 @@ do_install() {
31 ttydev=`echo $entry | sed -e 's/^[0-9]*\;//' -e 's/\;.*//'` 31 ttydev=`echo $entry | sed -e 's/^[0-9]*\;//' -e 's/\;.*//'`
32 if [ "$baudrate" = "$default_baudrate" ] ; then 32 if [ "$baudrate" = "$default_baudrate" ] ; then
33 # enable the service 33 # enable the service
34 ln -sf ${systemd_unitdir}/system/serial-getty@.service \ 34 ln -sf ${systemd_system_unitdir}/serial-getty@.service \
35 ${D}${sysconfdir}/systemd/system/getty.target.wants/serial-getty@$ttydev.service 35 ${D}${sysconfdir}/systemd/system/getty.target.wants/serial-getty@$ttydev.service
36 else 36 else
37 # install custom service file for the non-default baudrate 37 # install custom service file for the non-default baudrate
38 install -m 0644 ${WORKDIR}/serial-getty@.service ${D}${systemd_unitdir}/system/serial-getty$baudrate@.service 38 install -m 0644 ${WORKDIR}/serial-getty@.service ${D}${systemd_system_unitdir}/serial-getty$baudrate@.service
39 sed -i -e "s/\@BAUDRATE\@/$baudrate/g" ${D}${systemd_unitdir}/system/serial-getty$baudrate@.service 39 sed -i -e "s/\@BAUDRATE\@/$baudrate/g" ${D}${systemd_system_unitdir}/serial-getty$baudrate@.service
40 # enable the service 40 # enable the service
41 ln -sf ${systemd_unitdir}/system/serial-getty$baudrate@.service \ 41 ln -sf ${systemd_system_unitdir}/serial-getty$baudrate@.service \
42 ${D}${sysconfdir}/systemd/system/getty.target.wants/serial-getty$baudrate@$ttydev.service 42 ${D}${sysconfdir}/systemd/system/getty.target.wants/serial-getty$baudrate@$ttydev.service
43 fi 43 fi
44 done 44 done
@@ -46,7 +46,7 @@ do_install() {
46} 46}
47 47
48# This is a machine specific file 48# This is a machine specific file
49FILES:${PN} = "${systemd_unitdir}/system/*.service ${sysconfdir}" 49FILES:${PN} = "${systemd_system_unitdir}/*.service ${sysconfdir}"
50PACKAGE_ARCH = "${MACHINE_ARCH}" 50PACKAGE_ARCH = "${MACHINE_ARCH}"
51 51
52ALLOW_EMPTY:${PN} = "1" 52ALLOW_EMPTY:${PN} = "1"