summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/systemd/systemd-serialgetty.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/systemd/systemd-serialgetty.bb')
-rw-r--r--meta/recipes-core/systemd/systemd-serialgetty.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta/recipes-core/systemd/systemd-serialgetty.bb b/meta/recipes-core/systemd/systemd-serialgetty.bb
index 3e2a0e36f5..96cbf31470 100644
--- a/meta/recipes-core/systemd/systemd-serialgetty.bb
+++ b/meta/recipes-core/systemd/systemd-serialgetty.bb
@@ -40,3 +40,9 @@ RDEPENDS_${PN} = "systemd"
40# This is a machine specific file 40# This is a machine specific file
41FILES_${PN} = "${systemd_unitdir}/system/serial-getty@.service ${sysconfdir}" 41FILES_${PN} = "${systemd_unitdir}/system/serial-getty@.service ${sysconfdir}"
42PACKAGE_ARCH = "${MACHINE_ARCH}" 42PACKAGE_ARCH = "${MACHINE_ARCH}"
43
44# As this package is tied to systemd, only build it when we're also building systemd.
45python () {
46 if not oe.utils.contains ('DISTRO_FEATURES', 'systemd', True, False, d):
47 raise bb.parse.SkipPackage("'systemd' not in DISTRO_FEATURES")
48}