summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/systemd/systemd-compat-units.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/systemd/systemd-compat-units.bb')
-rw-r--r--meta/recipes-core/systemd/systemd-compat-units.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/meta/recipes-core/systemd/systemd-compat-units.bb b/meta/recipes-core/systemd/systemd-compat-units.bb
index c47c14bf95..6eb5ffd985 100644
--- a/meta/recipes-core/systemd/systemd-compat-units.bb
+++ b/meta/recipes-core/systemd/systemd-compat-units.bb
@@ -14,6 +14,8 @@ SRC_URI = "file://*.service"
14do_install() { 14do_install() {
15 install -d ${D}${systemd_unitdir}/system/basic.target.wants 15 install -d ${D}${systemd_unitdir}/system/basic.target.wants
16 install -d ${D}${systemd_unitdir}/system/sysinit.target.wants/ 16 install -d ${D}${systemd_unitdir}/system/sysinit.target.wants/
17 sed -i -e 's,@POSTINSTALL_INITPOSITION@,${POSTINSTALL_INITPOSITION},g' \
18 ${WORKDIR}/run-postinsts.service
17 install -m 0644 ${WORKDIR}/run-postinsts.service ${D}${systemd_unitdir}/system 19 install -m 0644 ${WORKDIR}/run-postinsts.service ${D}${systemd_unitdir}/system
18 ln -sf ../run-postinsts.service ${D}${systemd_unitdir}/system/basic.target.wants/ 20 ln -sf ../run-postinsts.service ${D}${systemd_unitdir}/system/basic.target.wants/
19 ln -sf ../run-postinsts.service ${D}${systemd_unitdir}/system/sysinit.target.wants/ 21 ln -sf ../run-postinsts.service ${D}${systemd_unitdir}/system/sysinit.target.wants/
@@ -53,4 +55,8 @@ pkg_postinst_${PN} () {
53FILES_${PN} = "${systemd_unitdir}/system ${bindir}" 55FILES_${PN} = "${systemd_unitdir}/system ${bindir}"
54RDPEPENDS_${PN} = "systemd" 56RDPEPENDS_${PN} = "systemd"
55 57
56 58# Define a variable to allow distros to run configure earlier.
59# (for example, to enable loading of ethernet kernel modules before networking starts)
60# note: modifying name or default value for POSTINSTALL_INITPOSITION requires
61# changes in opkg.inc
62POSTINSTALL_INITPOSITION ?= "98"