summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/systemd/systemd-boot_243.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/systemd/systemd-boot_243.bb')
-rw-r--r--meta/recipes-core/systemd/systemd-boot_243.bb73
1 files changed, 73 insertions, 0 deletions
diff --git a/meta/recipes-core/systemd/systemd-boot_243.bb b/meta/recipes-core/systemd/systemd-boot_243.bb
new file mode 100644
index 0000000000..56a25c35ba
--- /dev/null
+++ b/meta/recipes-core/systemd/systemd-boot_243.bb
@@ -0,0 +1,73 @@
1require systemd.inc
2FILESEXTRAPATHS =. "${FILE_DIRNAME}/systemd:"
3
4DEPENDS = "intltool-native libcap util-linux gnu-efi gperf-native"
5
6# NOTE: These three patches are in theory not needed, but we haven't
7# figured out how to correctly pass efi-cc parameter if it's an array.
8SRC_URI += "file://0001-Revert-meson-use-an-array-option-for-efi-cc.patch \
9 file://0001-Revert-meson-print-EFI-CC-configuration-nicely.patch \
10 file://0001-Fix-to-run-efi_cc-and-efi_ld-correctly-when-cross-co.patch \
11 file://0001-meson-Add-Defi-objcopy-option-to-specify-objcopy.patch \
12 "
13
14inherit meson pkgconfig gettext
15inherit deploy
16
17EFI_CC ?= "${CC}"
18EXTRA_OEMESON += "-Defi=true \
19 -Dgnu-efi=true \
20 -Defi-includedir=${STAGING_INCDIR}/efi \
21 -Defi-ldsdir=${STAGING_LIBDIR} \
22 -Defi-libdir=${STAGING_LIBDIR} \
23 -Dman=false \
24 -Defi-cc='${EFI_CC}' \
25 -Defi-ld='${LD}' \
26 -Defi-objcopy='${OBJCOPY}' \
27 "
28
29# install to the image as boot*.efi if its the EFI_PROVIDER,
30# otherwise install as the full name.
31# This allows multiple bootloaders to coexist in a single image.
32python __anonymous () {
33 import re
34 target = d.getVar('TARGET_ARCH')
35 prefix = "" if d.getVar('EFI_PROVIDER') == "systemd-boot" else "systemd-"
36 if target == "x86_64":
37 systemdimage = prefix + "bootx64.efi"
38 else:
39 systemdimage = prefix + "bootia32.efi"
40 d.setVar("SYSTEMD_BOOT_IMAGE", systemdimage)
41 prefix = "systemd-" if prefix == "" else ""
42 d.setVar("SYSTEMD_BOOT_IMAGE_PREFIX", prefix)
43}
44
45FILES_${PN} = "/boot/EFI/BOOT/${SYSTEMD_BOOT_IMAGE}"
46
47RDEPENDS_${PN} += "virtual/systemd-bootconf"
48
49# Imported from the old gummiboot recipe
50TUNE_CCARGS_remove = "-mfpmath=sse"
51COMPATIBLE_HOST = "(x86_64.*|i.86.*)-linux"
52COMPATIBLE_HOST_x86-x32 = "null"
53
54do_compile() {
55 SYSTEMD_BOOT_EFI_ARCH="ia32"
56 if [ "${TARGET_ARCH}" = "x86_64" ]; then
57 SYSTEMD_BOOT_EFI_ARCH="x64"
58 fi
59
60 ninja src/boot/efi/${SYSTEMD_BOOT_IMAGE_PREFIX}${SYSTEMD_BOOT_IMAGE}
61}
62
63do_install() {
64 install -d ${D}/boot
65 install -d ${D}/boot/EFI
66 install -d ${D}/boot/EFI/BOOT
67 install ${B}/src/boot/efi/systemd-boot*.efi ${D}/boot/EFI/BOOT/${SYSTEMD_BOOT_IMAGE}
68}
69
70do_deploy () {
71 install ${B}/src/boot/efi/systemd-boot*.efi ${DEPLOYDIR}
72}
73addtask deploy before do_build after do_compile