summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/readline/readline_5.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/readline/readline_5.2.bb')
-rw-r--r--meta/recipes-core/readline/readline_5.2.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-core/readline/readline_5.2.bb b/meta/recipes-core/readline/readline_5.2.bb
new file mode 100644
index 0000000000..a62345c45e
--- /dev/null
+++ b/meta/recipes-core/readline/readline_5.2.bb
@@ -0,0 +1,35 @@
1DESCRIPTION = "The GNU Readline library provides a set of functions for use by applications that allow users to edit \
2command lines as they are typed in. Both Emacs and vi editing modes are available. The Readline library includes \
3additional functions to maintain a list of previously-entered command lines, to recall and perhaps reedit those \
4lines, and perform csh-like history expansion on previous commands."
5SECTION = "libs"
6
7LICENSE = "GPLv2+"
8LIC_FILES_CHKSUM = "file://COPYING;md5=03b36fdd84f74b8d8189a202b980b67f"
9
10DEPENDS += "ncurses"
11PRIORITY = "optional"
12
13PR = "r6"
14
15SRC_URI = "${GNU_MIRROR}/readline/${BPN}-${PV}.tar.gz \
16 file://configure-fix.patch \
17 file://acinclude.m4"
18
19S = "${WORKDIR}/${BPN}-${PV}"
20
21inherit autotools
22
23LEAD_SONAME = "libreadline.so"
24
25do_configure_prepend () {
26 install -m 0644 ${WORKDIR}/acinclude.m4 ${S}/
27}
28
29do_install_append () {
30 # Make install doesn't properly install these
31 oe_libinstall -so -C shlib libhistory ${D}${libdir}
32 oe_libinstall -so -C shlib libreadline ${D}${libdir}
33}
34
35BBCLASSEXTEND = "native nativesdk"