summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/psplash/psplash_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/psplash/psplash_svn.bb')
-rw-r--r--meta/recipes-core/psplash/psplash_svn.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-core/psplash/psplash_svn.bb b/meta/recipes-core/psplash/psplash_svn.bb
new file mode 100644
index 0000000000..1e53ef1f1b
--- /dev/null
+++ b/meta/recipes-core/psplash/psplash_svn.bb
@@ -0,0 +1,26 @@
1DESCRIPTION = "Userspace framebuffer boot logo based on usplash."
2HOMEPAGE = "http://svn.o-hand.com/view/misc/trunk/psplash/"
3SECTION = "base"
4LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://psplash.h;md5=a87c39812c1e37f3451567cc29a29c8f"
6
7PV = "0.0+svnr${SRCREV}"
8PR = "r5"
9
10SRC_URI = "svn://svn.o-hand.com/repos/misc/trunk;module=psplash;proto=http \
11 file://psplash-init"
12
13S = "${WORKDIR}/psplash"
14
15inherit autotools pkgconfig update-rc.d
16
17FILES_${PN} += "/mnt/.psplash"
18
19do_install_prepend() {
20 install -d ${D}/mnt/.psplash/
21 install -d ${D}${sysconfdir}/init.d/
22 install -m 0755 ${WORKDIR}/psplash-init ${D}${sysconfdir}/init.d/psplash.sh
23}
24
25INITSCRIPT_NAME = "psplash.sh"
26INITSCRIPT_PARAMS = "start 0 S . stop 20 0 1 6 ."