summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/psplash/psplash_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/psplash/psplash_git.bb')
-rw-r--r--meta/recipes-core/psplash/psplash_git.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-core/psplash/psplash_git.bb b/meta/recipes-core/psplash/psplash_git.bb
new file mode 100644
index 0000000000..9112aa9168
--- /dev/null
+++ b/meta/recipes-core/psplash/psplash_git.bb
@@ -0,0 +1,33 @@
1SUMMARY = "Userspace framebuffer boot logo based on usplash."
2DESCRIPTION = "PSplash is a userspace graphical boot splash screen for mainly embedded Linux devices supporting a 16bpp or 32bpp framebuffer. It has few dependencies (just libc), supports basic images and text and handles rotation. Its visual look is configurable by basic source changes. Also included is a 'client' command utility for sending information to psplash such as boot progress information."
3HOMEPAGE = "http://git.yoctoproject.org/cgit/cgit.cgi/psplash"
4SECTION = "base"
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://psplash.h;md5=a87c39812c1e37f3451567cc29a29c8f"
7
8SRCREV = "e05374aae945bcfc6d962ed0d7b2774b77987e1d"
9PV = "0.1+git${SRCPV}"
10PR = "r0"
11
12SRC_URI = "git://git.yoctoproject.org/${BPN};protocol=git \
13 file://psplash-init \
14 file://psplash-poky-img.h"
15
16S = "${WORKDIR}/git"
17
18inherit autotools pkgconfig update-rc.d
19
20FILES_${PN} += "/mnt/.psplash"
21
22do_configure_prepend () {
23 cp -f ${WORKDIR}/psplash-poky-img.h ${S}/
24}
25
26do_install_prepend() {
27 install -d ${D}/mnt/.psplash/
28 install -d ${D}${sysconfdir}/init.d/
29 install -m 0755 ${WORKDIR}/psplash-init ${D}${sysconfdir}/init.d/psplash.sh
30}
31
32INITSCRIPT_NAME = "psplash.sh"
33INITSCRIPT_PARAMS = "start 0 S . stop 20 0 1 6 ."