summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/packagegroups/packagegroup-core-tools-profile.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/packagegroups/packagegroup-core-tools-profile.bb')
-rw-r--r--meta/recipes-core/packagegroups/packagegroup-core-tools-profile.bb83
1 files changed, 83 insertions, 0 deletions
diff --git a/meta/recipes-core/packagegroups/packagegroup-core-tools-profile.bb b/meta/recipes-core/packagegroups/packagegroup-core-tools-profile.bb
new file mode 100644
index 0000000000..9eb1458baa
--- /dev/null
+++ b/meta/recipes-core/packagegroups/packagegroup-core-tools-profile.bb
@@ -0,0 +1,83 @@
1#
2# Copyright (C) 2008 OpenedHand Ltd.
3#
4
5SUMMARY = "Profiling tools"
6LICENSE = "MIT"
7
8PR = "r3"
9
10inherit packagegroup
11
12PACKAGE_ARCH = "${MACHINE_ARCH}"
13
14# For backwards compatibility after rename
15RPROVIDES_${PN} = "task-core-tools-profile"
16RREPLACES_${PN} = "task-core-tools-profile"
17RCONFLICTS_${PN} = "task-core-tools-profile"
18
19PROFILE_TOOLS_X = "${@base_contains('DISTRO_FEATURES', 'x11', 'sysprof', '', d)}"
20
21RRECOMMENDS_${PN} = "\
22 perf \
23 trace-cmd \
24 kernel-module-oprofile \
25 blktrace \
26 ${PROFILE_TOOLS_X} \
27 "
28
29PROFILETOOLS = "\
30 oprofile \
31 oprofileui-server \
32 powertop \
33 latencytop \
34 "
35
36# systemtap needs elfutils which is not fully buildable on uclibc
37# hence we exclude it from uclibc based builds
38SYSTEMTAP = "systemtap"
39SYSTEMTAP_libc-uclibc = ""
40SYSTEMTAP_mips = ""
41SYSTEMTAP_mips64 = ""
42SYSTEMTAP_aarch64 = ""
43
44# lttng-ust uses sched_getcpu() which is not there on uclibc
45# for some of the architectures it can be patched to call the
46# syscall directly but for x86_64 __NR_getcpu is a vsyscall
47# which means we can not use syscall() to call it. So we ignore
48# it for x86_64/uclibc
49
50LTTNGUST = "lttng-ust"
51LTTNGUST_libc-uclibc = ""
52LTTNGUST_aarch64 = ""
53
54LTTNGTOOLS = "lttng-tools"
55LTTNGTOOLS_aarch64 = ""
56
57LTTNGMODULES = "lttng-modules"
58LTTNGMODULES_aarch64 = ""
59
60BABELTRACE = "babeltrace"
61BABELTRACE_aarch64 = ""
62
63# valgrind does not work on mips
64
65VALGRIND = "valgrind"
66VALGRIND_libc-uclibc = ""
67VALGRIND_mips = ""
68VALGRIND_mips64 = ""
69VALGRIND_arm = ""
70VALGRIND_aarch64 = ""
71
72# exmap-console
73# exmap-server
74
75RDEPENDS_${PN} = "\
76 ${PROFILETOOLS} \
77 ${LTTNGUST} \
78 ${LTTNGTOOLS} \
79 ${LTTNGMODULES} \
80 ${BABELTRACE} \
81 ${SYSTEMTAP} \
82 ${VALGRIND} \
83 "