summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/packagegroups/packagegroup-core-tools-profile.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/packagegroups/packagegroup-core-tools-profile.bb')
-rw-r--r--meta/recipes-core/packagegroups/packagegroup-core-tools-profile.bb84
1 files changed, 84 insertions, 0 deletions
diff --git a/meta/recipes-core/packagegroups/packagegroup-core-tools-profile.bb b/meta/recipes-core/packagegroups/packagegroup-core-tools-profile.bb
new file mode 100644
index 0000000000..09e776c30b
--- /dev/null
+++ b/meta/recipes-core/packagegroups/packagegroup-core-tools-profile.bb
@@ -0,0 +1,84 @@
1#
2# Copyright (C) 2008 OpenedHand Ltd.
3#
4
5SUMMARY = "Profiling tools"
6LICENSE = "MIT"
7
8PR = "r3"
9
10PACKAGE_ARCH = "${MACHINE_ARCH}"
11
12inherit packagegroup
13
14PROFILE_TOOLS_X = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'sysprof', '', d)}"
15PROFILE_TOOLS_X_aarch64 = ""
16PROFILE_TOOLS_SYSTEMD = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd-analyze', '', d)}"
17
18RRECOMMENDS_${PN} = "\
19 perf \
20 trace-cmd \
21 kernel-module-oprofile \
22 blktrace \
23 ${PROFILE_TOOLS_X} \
24 ${PROFILE_TOOLS_SYSTEMD} \
25 "
26
27LATENCYTOP = "latencytop"
28LATENCYTOP_aarch64 = ""
29
30PROFILETOOLS = "\
31 oprofile \
32 oprofileui-server \
33 powertop \
34 ${LATENCYTOP} \
35 "
36
37# systemtap needs elfutils which is not fully buildable on uclibc
38# hence we exclude it from uclibc based builds
39SYSTEMTAP = "systemtap"
40SYSTEMTAP_libc-uclibc = ""
41SYSTEMTAP_mips = ""
42SYSTEMTAP_mips64 = ""
43SYSTEMTAP_mips64n32 = ""
44SYSTEMTAP_aarch64 = ""
45
46# lttng-ust uses sched_getcpu() which is not there on uclibc
47# for some of the architectures it can be patched to call the
48# syscall directly but for x86_64 __NR_getcpu is a vsyscall
49# which means we can not use syscall() to call it. So we ignore
50# it for x86_64/uclibc
51
52LTTNGUST = "lttng-ust"
53LTTNGUST_libc-uclibc = ""
54
55LTTNGTOOLS = "lttng-tools"
56
57LTTNGMODULES = "lttng-modules"
58LTTNGMODULES_aarch64 = ""
59LTTNGMODULES_arm = ""
60
61BABELTRACE = "babeltrace"
62
63# valgrind does not work on mips
64
65VALGRIND = "valgrind"
66VALGRIND_libc-uclibc = ""
67VALGRIND_mips = ""
68VALGRIND_mips64 = ""
69VALGRIND_mips64n32 = ""
70VALGRIND_arm = ""
71VALGRIND_aarch64 = ""
72
73# exmap-console
74# exmap-server
75
76RDEPENDS_${PN} = "\
77 ${PROFILETOOLS} \
78 ${LTTNGUST} \
79 ${LTTNGTOOLS} \
80 ${LTTNGMODULES} \
81 ${BABELTRACE} \
82 ${SYSTEMTAP} \
83 ${VALGRIND} \
84 "