summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/packagegroups/packagegroup-core-tools-profile.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/packagegroups/packagegroup-core-tools-profile.bb')
-rw-r--r--meta/recipes-core/packagegroups/packagegroup-core-tools-profile.bb71
1 files changed, 71 insertions, 0 deletions
diff --git a/meta/recipes-core/packagegroups/packagegroup-core-tools-profile.bb b/meta/recipes-core/packagegroups/packagegroup-core-tools-profile.bb
new file mode 100644
index 0000000000..30776ef658
--- /dev/null
+++ b/meta/recipes-core/packagegroups/packagegroup-core-tools-profile.bb
@@ -0,0 +1,71 @@
1#
2# Copyright (C) 2008 OpenedHand Ltd.
3#
4
5DESCRIPTION = "Profile tools tasks for OE-Core"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
8 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
9
10PACKAGES = "\
11 ${PN} \
12 ${PN}-dbg \
13 ${PN}-dev \
14 "
15
16PACKAGE_ARCH = "${MACHINE_ARCH}"
17
18ALLOW_EMPTY = "1"
19
20RRECOMMENDS_${PN} = "\
21 perf \
22 trace-cmd \
23 kernel-module-oprofile \
24 blktrace \
25 sysprof \
26 "
27
28PROFILETOOLS = "\
29 oprofile \
30 oprofileui-server \
31 powertop \
32 latencytop \
33 lttng-control \
34 lttng-viewer"
35
36# systemtap needs elfutils which is not fully buildable on uclibc
37# hence we exclude it from uclibc based builds
38SYSTEMTAP = "systemtap"
39SYSTEMTAP_libc-uclibc = ""
40SYSTEMTAP_mips = ""
41
42# lttng-ust uses sched_getcpu() which is not there on uclibc
43# for some of the architectures it can be patched to call the
44# syscall directly but for x86_64 __NR_getcpu is a vsyscall
45# which means we can not use syscall() to call it. So we ignore
46# it for x86_64/uclibc
47
48LTTNGUST = "lttng-ust"
49LTTNGUST_libc-uclibc = ""
50LTTNGUST_mips = ""
51
52# valgrind does not work on mips
53
54VALGRIND = "valgrind"
55VALGRIND_libc-uclibc = ""
56VALGRIND_mips = ""
57VALGRIND_arm = ""
58
59# exmap-console
60# exmap-server
61
62# At present we only build lttng-ust on
63# qemux86/qemux86-64/qemuppc/qemuarm/emenlow/atom-pc since upstream liburcu
64# (which is required by lttng-ust) may not build on other platforms, like
65# MIPS.
66RDEPENDS_${PN} = "\
67 ${PROFILETOOLS} \
68 ${LTTNGUST} \
69 ${SYSTEMTAP} \
70 ${VALGRIND} \
71 "