summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/packagegroups/packagegroup-core-boot.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/packagegroups/packagegroup-core-boot.bb')
-rw-r--r--meta/recipes-core/packagegroups/packagegroup-core-boot.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta/recipes-core/packagegroups/packagegroup-core-boot.bb b/meta/recipes-core/packagegroups/packagegroup-core-boot.bb
new file mode 100644
index 0000000000..09f537372e
--- /dev/null
+++ b/meta/recipes-core/packagegroups/packagegroup-core-boot.bb
@@ -0,0 +1,47 @@
1#
2# Copyright (C) 2007 OpenedHand Ltd.
3#
4
5SUMMARY = "Minimal boot requirements"
6DESCRIPTION = "The minimal set of packages required to boot the system"
7LICENSE = "MIT"
8PR = "r17"
9
10PACKAGE_ARCH = "${MACHINE_ARCH}"
11
12inherit packagegroup
13
14#
15# Set by the machine configuration with packages essential for device bootup
16#
17MACHINE_ESSENTIAL_EXTRA_RDEPENDS ?= ""
18MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS ?= ""
19
20# Distro can override the following VIRTUAL-RUNTIME providers:
21VIRTUAL-RUNTIME_dev_manager ?= "udev"
22VIRTUAL-RUNTIME_login_manager ?= "busybox"
23VIRTUAL-RUNTIME_init_manager ?= "sysvinit"
24VIRTUAL-RUNTIME_initscripts ?= "initscripts"
25VIRTUAL-RUNTIME_keymaps ?= "keymaps"
26
27SYSVINIT_SCRIPTS = "${@bb.utils.contains('MACHINE_FEATURES', 'rtc', 'busybox-hwclock', '', d)} \
28 modutils-initscripts \
29 init-ifupdown \
30 ${VIRTUAL-RUNTIME_initscripts} \
31 "
32
33RDEPENDS_${PN} = "\
34 base-files \
35 base-passwd \
36 busybox \
37 ${@bb.utils.contains("DISTRO_FEATURES", "sysvinit", "${SYSVINIT_SCRIPTS}", "", d)} \
38 ${@bb.utils.contains("MACHINE_FEATURES", "keyboard", "${VIRTUAL-RUNTIME_keymaps}", "", d)} \
39 netbase \
40 ${VIRTUAL-RUNTIME_login_manager} \
41 ${VIRTUAL-RUNTIME_init_manager} \
42 ${VIRTUAL-RUNTIME_dev_manager} \
43 ${VIRTUAL-RUNTIME_update-alternatives} \
44 ${MACHINE_ESSENTIAL_EXTRA_RDEPENDS}"
45
46RRECOMMENDS_${PN} = "\
47 ${MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS}"