summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/packagegroups/packagegroup-base.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/packagegroups/packagegroup-base.bb')
-rw-r--r--meta/recipes-core/packagegroups/packagegroup-base.bb9
1 files changed, 9 insertions, 0 deletions
diff --git a/meta/recipes-core/packagegroups/packagegroup-base.bb b/meta/recipes-core/packagegroups/packagegroup-base.bb
index f151591f18..217830801d 100644
--- a/meta/recipes-core/packagegroups/packagegroup-base.bb
+++ b/meta/recipes-core/packagegroups/packagegroup-base.bb
@@ -114,6 +114,15 @@ python __anonymous () {
114 114
115 if "3g" in distro_features and not "3g" in machine_features and ("pcmcia" in machine_features or "pci" in machine_features or "usbhost" in machine_features): 115 if "3g" in distro_features and not "3g" in machine_features and ("pcmcia" in machine_features or "pci" in machine_features or "usbhost" in machine_features):
116 d.setVar("ADD_3G", "packagegroup-base-3g") 116 d.setVar("ADD_3G", "packagegroup-base-3g")
117
118 # For backwards compatibility after rename
119 packages = d.getVar("PACKAGES", True).split()
120 packages.remove("packagegroup-distro-base")
121 packages.remove("packagegroup-machine-base")
122 for pkg in packages:
123 d.appendVar("RPROVIDES_%s" % pkg, pkg.replace("packagegroup-base", "task-base"))
124 d.appendVar("RPROVIDES_packagegroup-distro-base", "task-distro-base")
125 d.appendVar("RPROVIDES_packagegroup-machine-base", "task-machine-base")
117} 126}
118 127
119# 128#