summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/meta/package-index.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/meta/package-index.bb')
-rw-r--r--meta/recipes-core/meta/package-index.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-core/meta/package-index.bb b/meta/recipes-core/meta/package-index.bb
new file mode 100644
index 0000000000..21822fe9da
--- /dev/null
+++ b/meta/recipes-core/meta/package-index.bb
@@ -0,0 +1,29 @@
1DESCRIPTION = "Rebuild the package index"
2LICENSE = "MIT"
3
4INHIBIT_DEFAULT_DEPS = "1"
5ALLOW_EMPTY = "1"
6PACKAGES = ""
7
8do_fetch() {
9}
10do_unpack() {
11}
12do_patch() {
13}
14do_configure() {
15}
16do_compile() {
17}
18do_install() {
19}
20
21do_build[nostamp] = "1"
22do_build[dirs] = "${DEPLOY_DIR_IPK}"
23do_build() {
24 set -ex
25 package_update_index_ipk
26 set +ex
27}
28
29EXCLUDE_FROM_WORLD = "1"