summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/meta/nativesdk-buildtools-perl-dummy.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/meta/nativesdk-buildtools-perl-dummy.bb')
-rw-r--r--meta/recipes-core/meta/nativesdk-buildtools-perl-dummy.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta/recipes-core/meta/nativesdk-buildtools-perl-dummy.bb b/meta/recipes-core/meta/nativesdk-buildtools-perl-dummy.bb
new file mode 100644
index 0000000000..a3cf9d754a
--- /dev/null
+++ b/meta/recipes-core/meta/nativesdk-buildtools-perl-dummy.bb
@@ -0,0 +1,18 @@
1SUMMARY = "Dummy package which ensures perl is excluded from buildtools"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
4
5inherit nativesdk
6
7# Put it somewhere separate to ensure it's never used except when we want it
8PACKAGE_ARCH = "buildtools-dummy-${SDKPKGSUFFIX}"
9
10PERLPACKAGES = "nativesdk-perl \
11 nativesdk-perl-module-file-path"
12
13ALLOW_EMPTY_${PN} = "1"
14
15python populate_packages_prepend() {
16 d.appendVar('RPROVIDES_${PN}', '${PERLPACKAGES}')
17 d.appendVar('RCONFLICTS_${PN}', '${PERLPACKAGES}')
18}