summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/meta/meta-ide-support.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/meta/meta-ide-support.bb')
-rw-r--r--meta/recipes-core/meta/meta-ide-support.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta/recipes-core/meta/meta-ide-support.bb b/meta/recipes-core/meta/meta-ide-support.bb
new file mode 100644
index 0000000000..130b1c9494
--- /dev/null
+++ b/meta/recipes-core/meta/meta-ide-support.bb
@@ -0,0 +1,17 @@
1DESCRIPTION = "Meta package for ensuring the build directory contains all appropriate toolchain packages for using an IDE"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
4 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
5
6DEPENDS = "virtual/libc gdb-cross qemu-native qemu-helper-native unfs-server-native"
7PR = "r3"
8
9inherit meta toolchain-scripts
10
11do_populate_ide_support () {
12 toolchain_create_tree_env_script
13}
14
15do_populate_ide_support[nostamp] = "1"
16do_populate_ide_support[recrdeptask] = "do_package_write"
17addtask populate_ide_support before do_build after do_install