summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/meta/meta-extsdk-toolchain.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/meta/meta-extsdk-toolchain.bb')
-rw-r--r--meta/recipes-core/meta/meta-extsdk-toolchain.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta/recipes-core/meta/meta-extsdk-toolchain.bb b/meta/recipes-core/meta/meta-extsdk-toolchain.bb
index 9bff22053c..886ff076dc 100644
--- a/meta/recipes-core/meta/meta-extsdk-toolchain.bb
+++ b/meta/recipes-core/meta/meta-extsdk-toolchain.bb
@@ -11,3 +11,18 @@ do_populate_sysroot[deptask] = "do_populate_sysroot"
11# NOTE: There is logic specific to this recipe in setscene_depvalid() 11# NOTE: There is logic specific to this recipe in setscene_depvalid()
12# within sstate.bbclass, so if you copy or rename this and expect the same 12# within sstate.bbclass, so if you copy or rename this and expect the same
13# functionality you'll need to modify that as well. 13# functionality you'll need to modify that as well.
14
15LOCKED_SIGS_INDIR = "${D}/locked-sigs"
16
17addtask do_locked_sigs after do_populate_sysroot
18SSTATETASKS += "do_locked_sigs"
19do_locked_sigs[sstate-inputdirs] = "${LOCKED_SIGS_INDIR}"
20do_locked_sigs[sstate-outputdirs] = "${STAGING_DIR_HOST}/locked-sigs"
21
22python do_locked_sigs() {
23 import oe.copy_buildsystem
24 outdir = os.path.join(d.getVar('LOCKED_SIGS_INDIR', True))
25 bb.utils.mkdirhier(outdir)
26 sigfile = os.path.join(outdir, 'locked-sigs-extsdk-toolchain.inc')
27 oe.copy_buildsystem.generate_locked_sigs(sigfile, d)
28}