summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/meta/meta-environment.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/meta/meta-environment.bb')
-rw-r--r--meta/recipes-core/meta/meta-environment.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-core/meta/meta-environment.bb b/meta/recipes-core/meta/meta-environment.bb
index 71e0c23186..a250cc89fe 100644
--- a/meta/recipes-core/meta/meta-environment.bb
+++ b/meta/recipes-core/meta/meta-environment.bb
@@ -26,16 +26,16 @@ python do_generate_content() {
26 localdata = bb.data.createCopy(d) 26 localdata = bb.data.createCopy(d)
27 27
28 # make sure we only use the WORKDIR value from 'd', or it can change 28 # make sure we only use the WORKDIR value from 'd', or it can change
29 localdata.setVar('WORKDIR', d.getVar('WORKDIR', True)) 29 localdata.setVar('WORKDIR', d.getVar('WORKDIR'))
30 30
31 # make sure we only use the SDKTARGETSYSROOT value from 'd' 31 # make sure we only use the SDKTARGETSYSROOT value from 'd'
32 localdata.setVar('SDKTARGETSYSROOT', d.getVar('SDKTARGETSYSROOT', True)) 32 localdata.setVar('SDKTARGETSYSROOT', d.getVar('SDKTARGETSYSROOT'))
33 localdata.setVar('libdir', d.getVar('target_libdir', False)) 33 localdata.setVar('libdir', d.getVar('target_libdir', False))
34 34
35 # Process DEFAULTTUNE 35 # Process DEFAULTTUNE
36 bb.build.exec_func("create_sdk_files", localdata) 36 bb.build.exec_func("create_sdk_files", localdata)
37 37
38 variants = d.getVar("MULTILIB_VARIANTS", True) or "" 38 variants = d.getVar("MULTILIB_VARIANTS") or ""
39 for item in variants.split(): 39 for item in variants.split():
40 # Load overrides from 'd' to avoid having to reset the value... 40 # Load overrides from 'd' to avoid having to reset the value...
41 overrides = d.getVar("OVERRIDES", False) + ":virtclass-multilib-" + item 41 overrides = d.getVar("OVERRIDES", False) + ":virtclass-multilib-" + item