summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/meta/cve-update-db-native.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/meta/cve-update-db-native.bb')
-rw-r--r--meta/recipes-core/meta/cve-update-db-native.bb10
1 files changed, 9 insertions, 1 deletions
diff --git a/meta/recipes-core/meta/cve-update-db-native.bb b/meta/recipes-core/meta/cve-update-db-native.bb
index 2c427a5884..19875a49b1 100644
--- a/meta/recipes-core/meta/cve-update-db-native.bb
+++ b/meta/recipes-core/meta/cve-update-db-native.bb
@@ -31,8 +31,16 @@ python do_populate_cve_db() {
31 db_dir = os.path.join(d.getVar("DL_DIR"), 'CVE_CHECK') 31 db_dir = os.path.join(d.getVar("DL_DIR"), 'CVE_CHECK')
32 db_file = os.path.join(db_dir, 'nvdcve_1.0.db') 32 db_file = os.path.join(db_dir, 'nvdcve_1.0.db')
33 json_tmpfile = os.path.join(db_dir, 'nvd.json.gz') 33 json_tmpfile = os.path.join(db_dir, 'nvd.json.gz')
34 proxy = d.getVar("https_proxy")
35 34
35 # Don't refresh the database more than once an hour
36 try:
37 import time
38 if time.time() - os.path.getmtime(db_file) < (60*60):
39 return
40 except OSError:
41 pass
42
43 proxy = d.getVar("https_proxy")
36 if proxy: 44 if proxy:
37 # instantiate an opener but do not install it as the global 45 # instantiate an opener but do not install it as the global
38 # opener unless if we're really sure it's applicable for all 46 # opener unless if we're really sure it's applicable for all