summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/meta/cve-update-db-native.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/meta/cve-update-db-native.bb')
-rw-r--r--meta/recipes-core/meta/cve-update-db-native.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta/recipes-core/meta/cve-update-db-native.bb b/meta/recipes-core/meta/cve-update-db-native.bb
index af2946b5f8..35f74722cf 100644
--- a/meta/recipes-core/meta/cve-update-db-native.bb
+++ b/meta/recipes-core/meta/cve-update-db-native.bb
@@ -24,11 +24,11 @@ python do_populate_cve_db() {
24 BASE_URL = "https://nvd.nist.gov/feeds/json/cve/1.0/nvdcve-1.0-" 24 BASE_URL = "https://nvd.nist.gov/feeds/json/cve/1.0/nvdcve-1.0-"
25 YEAR_START = 2002 25 YEAR_START = 2002
26 26
27 db_dir = d.getVar("DL_DIR") + '/CVE_CHECK' 27 db_dir = os.path.join(d.getVar("DL_DIR"), 'CVE_CHECK')
28 db_file = db_dir + '/nvdcve_1.0.db' 28 db_file = os.path.join(db_dir, 'nvdcve_1.0.db')
29 json_tmpfile = db_dir + '/nvd.json.gz' 29 json_tmpfile = os.path.join(db_dir, 'nvd.json.gz')
30 proxy = d.getVar("https_proxy") 30 proxy = d.getVar("https_proxy")
31 cve_f = open(d.getVar("TMPDIR") + '/cve_check', 'a') 31 cve_f = open(os.path.join(d.getVar("TMPDIR"), 'cve_check'), 'a')
32 32
33 if not os.path.isdir(db_dir): 33 if not os.path.isdir(db_dir):
34 os.mkdir(db_dir) 34 os.mkdir(db_dir)