summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/meta/buildtools-tarball.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/meta/buildtools-tarball.bb')
-rw-r--r--meta/recipes-core/meta/buildtools-tarball.bb69
1 files changed, 69 insertions, 0 deletions
diff --git a/meta/recipes-core/meta/buildtools-tarball.bb b/meta/recipes-core/meta/buildtools-tarball.bb
new file mode 100644
index 0000000000..54fba11f8d
--- /dev/null
+++ b/meta/recipes-core/meta/buildtools-tarball.bb
@@ -0,0 +1,69 @@
1DESCRIPTION = "SDK type target for building a standalone tarball containing python, chrpath, make, git and tar. The \
2 tarball can be used to run bitbake builds on systems which don't meet the usual version requirements."
3SUMMARY = "Standalone tarball for running builds on systems with inadequate software"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
6 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
7
8TOOLCHAIN_TARGET_TASK ?= ""
9
10TOOLCHAIN_HOST_TASK ?= "\
11 nativesdk-python-core \
12 nativesdk-python-textutils \
13 nativesdk-python-sqlite3 \
14 nativesdk-python-pickle \
15 nativesdk-python-logging \
16 nativesdk-python-elementtree \
17 nativesdk-python-curses \
18 nativesdk-python-compile \
19 nativesdk-python-compiler \
20 nativesdk-python-fcntl \
21 nativesdk-python-shell \
22 nativesdk-python-misc \
23 nativesdk-python-multiprocessing \
24 nativesdk-python-subprocess \
25 nativesdk-python-xmlrpc \
26 nativesdk-python-netclient \
27 nativesdk-python-netserver \
28 nativesdk-python-distutils \
29 nativesdk-python-unixadmin \
30 nativesdk-python-compression \
31 nativesdk-python-json \
32 nativesdk-python-unittest \
33 nativesdk-python-mmap \
34 nativesdk-python-difflib \
35 nativesdk-python-pprint \
36 nativesdk-python-git \
37 nativesdk-python-pkgutil \
38 nativesdk-ncurses-terminfo-base \
39 nativesdk-chrpath \
40 nativesdk-tar \
41 nativesdk-git \
42 nativesdk-make \
43 "
44
45TOOLCHAIN_OUTPUTNAME ?= "${SDK_NAME}-buildtools-nativesdk-standalone-${DISTRO_VERSION}"
46
47RDEPENDS = "${TOOLCHAIN_HOST_TASK}"
48
49EXCLUDE_FROM_WORLD = "1"
50
51inherit meta
52inherit populate_sdk
53
54create_sdk_files_append () {
55 rm -f ${SDK_OUTPUT}/${SDKPATH}/site-config-*
56 rm -f ${SDK_OUTPUT}/${SDKPATH}/environment-setup-*
57 rm -f ${SDK_OUTPUT}/${SDKPATH}/version-*
58
59 # Generate new (mini) sdk-environment-setup file
60 script=${1:-${SDK_OUTPUT}/${SDKPATH}/environment-setup-${SDK_SYS}}
61 touch $script
62 echo 'export PATH=${SDKPATHNATIVE}${bindir_nativesdk}:$PATH' >> $script
63 # In order for the self-extraction script to correctly extract and set up things,
64 # we need a 'OECORE_NATIVE_SYSROOT=xxx' line in environment setup script.
65 # However, buildtools-tarball is inherently a tool set instead of a fully functional SDK,
66 # so instead of exporting the variable, we use a comment here.
67 echo '#OECORE_NATIVE_SYSROOT="${SDKPATHNATIVE}"' >> $script
68 toolchain_create_sdk_version ${SDK_OUTPUT}/${SDKPATH}/version-${SDK_SYS}
69}