summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/meta/buildtools-tarball.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/meta/buildtools-tarball.bb')
-rw-r--r--meta/recipes-core/meta/buildtools-tarball.bb71
1 files changed, 71 insertions, 0 deletions
diff --git a/meta/recipes-core/meta/buildtools-tarball.bb b/meta/recipes-core/meta/buildtools-tarball.bb
new file mode 100644
index 0000000000..c54d9e8699
--- /dev/null
+++ b/meta/recipes-core/meta/buildtools-tarball.bb
@@ -0,0 +1,71 @@
1DESCRIPTION = "SDK type target for building a standalone tarball containing python, chrpath, make, git and tar. The \
2 tarball can be used to run bitbake builds on systems which don't meet the usual version requirements."
3SUMMARY = "Standalone tarball for running builds on systems with inadequate software"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690 \
6 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
7
8TOOLCHAIN_TARGET_TASK ?= ""
9
10TOOLCHAIN_HOST_TASK ?= "\
11 nativesdk-python-core \
12 nativesdk-python-textutils \
13 nativesdk-python-sqlite3 \
14 nativesdk-python-pickle \
15 nativesdk-python-logging \
16 nativesdk-python-elementtree \
17 nativesdk-python-curses \
18 nativesdk-python-compile \
19 nativesdk-python-compiler \
20 nativesdk-python-fcntl \
21 nativesdk-python-shell \
22 nativesdk-python-misc \
23 nativesdk-python-multiprocessing \
24 nativesdk-python-subprocess \
25 nativesdk-python-xmlrpc \
26 nativesdk-python-netclient \
27 nativesdk-python-netserver \
28 nativesdk-python-distutils \
29 nativesdk-python-unixadmin \
30 nativesdk-python-compression \
31 nativesdk-python-json \
32 nativesdk-python-unittest \
33 nativesdk-python-mmap \
34 nativesdk-python-difflib \
35 nativesdk-python-pprint \
36 nativesdk-python-git \
37 nativesdk-python-pkgutil \
38 nativesdk-ncurses-terminfo-base \
39 nativesdk-chrpath \
40 nativesdk-tar \
41 nativesdk-git \
42 nativesdk-pigz \
43 nativesdk-make \
44 nativesdk-wget \
45 "
46
47TOOLCHAIN_OUTPUTNAME ?= "${SDK_NAME}-buildtools-nativesdk-standalone-${DISTRO_VERSION}"
48
49RDEPENDS = "${TOOLCHAIN_HOST_TASK}"
50
51EXCLUDE_FROM_WORLD = "1"
52
53inherit meta
54inherit populate_sdk
55
56create_sdk_files_append () {
57 rm -f ${SDK_OUTPUT}/${SDKPATH}/site-config-*
58 rm -f ${SDK_OUTPUT}/${SDKPATH}/environment-setup-*
59 rm -f ${SDK_OUTPUT}/${SDKPATH}/version-*
60
61 # Generate new (mini) sdk-environment-setup file
62 script=${1:-${SDK_OUTPUT}/${SDKPATH}/environment-setup-${SDK_SYS}}
63 touch $script
64 echo 'export PATH=${SDKPATHNATIVE}${bindir_nativesdk}:$PATH' >> $script
65 # In order for the self-extraction script to correctly extract and set up things,
66 # we need a 'OECORE_NATIVE_SYSROOT=xxx' line in environment setup script.
67 # However, buildtools-tarball is inherently a tool set instead of a fully functional SDK,
68 # so instead of exporting the variable, we use a comment here.
69 echo '#OECORE_NATIVE_SYSROOT="${SDKPATHNATIVE}"' >> $script
70 toolchain_create_sdk_version ${SDK_OUTPUT}/${SDKPATH}/version-${SDK_SYS}
71}