summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/meta/build-sysroots.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/meta/build-sysroots.bb')
-rw-r--r--meta/recipes-core/meta/build-sysroots.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-core/meta/build-sysroots.bb b/meta/recipes-core/meta/build-sysroots.bb
new file mode 100644
index 0000000000..7a712e2f38
--- /dev/null
+++ b/meta/recipes-core/meta/build-sysroots.bb
@@ -0,0 +1,38 @@
1INHIBIT_DEFAULT_DEPS = "1"
2LICENSE = "MIT"
3
4STANDALONE_SYSROOT = "${STAGING_DIR}/${MACHINE}"
5STANDALONE_SYSROOT_NATIVE = "${STAGING_DIR}/${BUILD_ARCH}"
6PACKAGE_ARCH = "${MACHINE_ARCH}"
7EXCLUDE_FROM_WORLD = "1"
8
9inherit nopackages
10deltask fetch
11deltask unpack
12deltask patch
13deltask prepare_recipe_sysroot
14deltask populate_lic
15deltask configure
16deltask compile
17deltask install
18deltask populate_sysroot
19
20python do_build_native_sysroot () {
21 targetsysroot = d.getVar("STANDALONE_SYSROOT")
22 nativesysroot = d.getVar("STANDALONE_SYSROOT_NATIVE")
23 staging_populate_sysroot_dir(targetsysroot, nativesysroot, True, d)
24}
25do_build_native_sysroot[cleandirs] = "${STANDALONE_SYSROOT_NATIVE}"
26do_build_native_sysroot[nostamp] = "1"
27addtask do_build_native_sysroot before do_build
28
29python do_build_target_sysroot () {
30 targetsysroot = d.getVar("STANDALONE_SYSROOT")
31 nativesysroot = d.getVar("STANDALONE_SYSROOT_NATIVE")
32 staging_populate_sysroot_dir(targetsysroot, nativesysroot, False, d)
33}
34do_build_target_sysroot[cleandirs] = "${STANDALONE_SYSROOT}"
35do_build_target_sysroot[nostamp] = "1"
36addtask do_build_target_sysroot before do_build
37
38do_clean[cleandirs] += "${STANDALONE_SYSROOT} ${STANDALONE_SYSROOT_NATIVE}"