summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/libxml/libxml2_2.9.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/libxml/libxml2_2.9.9.bb')
-rw-r--r--meta/recipes-core/libxml/libxml2_2.9.9.bb110
1 files changed, 110 insertions, 0 deletions
diff --git a/meta/recipes-core/libxml/libxml2_2.9.9.bb b/meta/recipes-core/libxml/libxml2_2.9.9.bb
new file mode 100644
index 0000000000..c38f883e44
--- /dev/null
+++ b/meta/recipes-core/libxml/libxml2_2.9.9.bb
@@ -0,0 +1,110 @@
1SUMMARY = "XML C Parser Library and Toolkit"
2DESCRIPTION = "The XML Parser Library allows for manipulation of XML files. Libxml2 exports Push and Pull type parser interfaces for both XML and HTML. It can do DTD validation at parse time, on a parsed document instance or with an arbitrary DTD. Libxml2 includes complete XPath, XPointer and Xinclude implementations. It also has a SAX like interface, which is designed to be compatible with Expat."
3HOMEPAGE = "http://www.xmlsoft.org/"
4BUGTRACKER = "http://bugzilla.gnome.org/buglist.cgi?product=libxml2"
5SECTION = "libs"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://Copyright;md5=2044417e2e5006b65a8b9067b683fcf1 \
8 file://hash.c;beginline=6;endline=15;md5=96f7296605eae807670fb08947829969 \
9 file://list.c;beginline=4;endline=13;md5=cdbfa3dee51c099edb04e39f762ee907 \
10 file://trio.c;beginline=5;endline=14;md5=6c025753c86d958722ec76e94cae932e"
11
12DEPENDS = "zlib virtual/libiconv"
13
14SRC_URI = "http://www.xmlsoft.org/sources/libxml2-${PV}.tar.gz;name=libtar \
15 http://www.w3.org/XML/Test/xmlts20080827.tar.gz;subdir=${BP};name=testtar \
16 file://libxml-64bit.patch \
17 file://runtest.patch \
18 file://run-ptest \
19 file://python-sitepackages-dir.patch \
20 file://libxml-m4-use-pkgconfig.patch \
21 file://0001-Make-ptest-run-the-python-tests-if-python-is-enabled.patch \
22 file://fix-execution-of-ptests.patch \
23 "
24
25SRC_URI[libtar.md5sum] = "c04a5a0a042eaa157e8e8c9eabe76bd6"
26SRC_URI[libtar.sha256sum] = "94fb70890143e3c6549f265cee93ec064c80a84c42ad0f23e85ee1fd6540a871"
27SRC_URI[testtar.md5sum] = "ae3d1ebe000a3972afa104ca7f0e1b4a"
28SRC_URI[testtar.sha256sum] = "96151685cec997e1f9f3387e3626d61e6284d4d6e66e0e440c209286c03e9cc7"
29
30BINCONFIG = "${bindir}/xml2-config"
31
32PACKAGECONFIG ??= "python \
33 ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \
34"
35PACKAGECONFIG[python] = "--with-python=${PYTHON},--without-python,python3"
36PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
37
38inherit autotools pkgconfig binconfig-disabled ptest distro_features_check
39
40inherit ${@bb.utils.contains('PACKAGECONFIG', 'python', 'python3native', '', d)}
41
42RDEPENDS_${PN}-ptest += "make ${@bb.utils.contains('PACKAGECONFIG', 'python', 'libgcc python3-core python3-logging python3-shell python3-stringold python3-threading python3-unittest ${PN}-python', '', d)}"
43
44RDEPENDS_${PN}-python += "${@bb.utils.contains('PACKAGECONFIG', 'python', 'python3-core', '', d)}"
45
46RDEPENDS_${PN}-ptest_append_libc-glibc = " glibc-gconv-ebcdic-us \
47 glibc-gconv-ibm1141 \
48 glibc-gconv-iso8859-5 \
49 glibc-gconv-euc-jp \
50 locale-base-en-us \
51 "
52
53export PYTHON_SITE_PACKAGES="${PYTHON_SITEPACKAGES_DIR}"
54
55# WARNING: zlib is required for RPM use
56EXTRA_OECONF = "--without-debug --without-legacy --with-catalog --without-docbook --with-c14n --without-lzma --with-fexceptions"
57EXTRA_OECONF_class-native = "--without-legacy --without-docbook --with-c14n --without-lzma --with-zlib"
58EXTRA_OECONF_class-nativesdk = "--without-legacy --without-docbook --with-c14n --without-lzma --with-zlib"
59EXTRA_OECONF_linuxstdbase = "--with-debug --with-legacy --with-docbook --with-c14n --without-lzma --with-zlib"
60
61python populate_packages_prepend () {
62 # autonamer would call this libxml2-2, but we don't want that
63 if d.getVar('DEBIAN_NAMES'):
64 d.setVar('PKG_libxml2', '${MLPREFIX}libxml2')
65}
66
67PACKAGE_BEFORE_PN += "${PN}-utils"
68PACKAGES += "${PN}-python"
69
70FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/*.a"
71FILES_${PN}-dev += "${libdir}/xml2Conf.sh ${libdir}/cmake/*"
72FILES_${PN}-utils = "${bindir}/*"
73FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR}"
74
75do_configure_prepend () {
76 # executables take longer to package: these should not be executable
77 find ${S}/xmlconf/ -type f -exec chmod -x {} \+
78}
79
80do_compile_ptest() {
81 oe_runmake check-am
82}
83
84do_install_ptest () {
85 cp -r ${S}/xmlconf ${D}${PTEST_PATH}
86 if [ "${@bb.utils.filter('PACKAGECONFIG', 'python', d)}" ]; then
87 sed -i -e 's|^\(PYTHON = \).*|\1${USRBINPATH}/${PYTHON_PN}|' \
88 ${D}${PTEST_PATH}/python/tests/Makefile
89 grep -lrZ '#!/usr/bin/python' ${D}${PTEST_PATH}/python |
90 xargs -0 sed -i -e 's|/usr/bin/python|${USRBINPATH}/${PYTHON_PN}|'
91 fi
92 #Remove build host references from various Makefiles
93 find "${D}${PTEST_PATH}" -name Makefile -type f -exec \
94 sed -i \
95 -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
96 -e 's|${DEBUG_PREFIX_MAP}||g' \
97 -e 's:${HOSTTOOLS_DIR}/::g' \
98 -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
99 -e 's:${RECIPE_SYSROOT}::g' \
100 -e 's:${BASE_WORKDIR}/${MULTIMACH_TARGET_SYS}::g' \
101 -e '/^RELDATE/d' \
102 {} +
103}
104
105do_install_append_class-native () {
106 # Docs are not needed in the native case
107 rm ${D}${datadir}/gtk-doc -rf
108}
109
110BBCLASSEXTEND = "native nativesdk"