summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/libxml/libxml2_2.9.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/libxml/libxml2_2.9.4.bb')
-rw-r--r--meta/recipes-core/libxml/libxml2_2.9.4.bb73
1 files changed, 73 insertions, 0 deletions
diff --git a/meta/recipes-core/libxml/libxml2_2.9.4.bb b/meta/recipes-core/libxml/libxml2_2.9.4.bb
new file mode 100644
index 0000000000..54231a5aa7
--- /dev/null
+++ b/meta/recipes-core/libxml/libxml2_2.9.4.bb
@@ -0,0 +1,73 @@
1SUMMARY = "XML C Parser Library and Toolkit"
2DESCRIPTION = "The XML Parser Library allows for manipulation of XML files. Libxml2 exports Push and Pull type parser interfaces for both XML and HTML. It can do DTD validation at parse time, on a parsed document instance or with an arbitrary DTD. Libxml2 includes complete XPath, XPointer and Xinclude implementations. It also has a SAX like interface, which is designed to be compatible with Expat."
3HOMEPAGE = "http://www.xmlsoft.org/"
4BUGTRACKER = "http://bugzilla.gnome.org/buglist.cgi?product=libxml2"
5SECTION = "libs"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://Copyright;md5=2044417e2e5006b65a8b9067b683fcf1 \
8 file://hash.c;beginline=6;endline=15;md5=96f7296605eae807670fb08947829969 \
9 file://list.c;beginline=4;endline=13;md5=cdbfa3dee51c099edb04e39f762ee907 \
10 file://trio.c;beginline=5;endline=14;md5=6c025753c86d958722ec76e94cae932e"
11
12DEPENDS = "zlib virtual/libiconv"
13
14SRC_URI = "ftp://xmlsoft.org/libxml2/libxml2-${PV}.tar.gz;name=libtar \
15 http://www.w3.org/XML/Test/xmlts20080827.tar.gz;name=testtar \
16 file://libxml-64bit.patch \
17 file://ansidecl.patch \
18 file://runtest.patch \
19 file://run-ptest \
20 file://python-sitepackages-dir.patch \
21 file://libxml-m4-use-pkgconfig.patch \
22 "
23
24SRC_URI[libtar.md5sum] = "ae249165c173b1ff386ee8ad676815f5"
25SRC_URI[libtar.sha256sum] = "ffb911191e509b966deb55de705387f14156e1a56b21824357cdf0053233633c"
26SRC_URI[testtar.md5sum] = "ae3d1ebe000a3972afa104ca7f0e1b4a"
27SRC_URI[testtar.sha256sum] = "96151685cec997e1f9f3387e3626d61e6284d4d6e66e0e440c209286c03e9cc7"
28
29BINCONFIG = "${bindir}/xml2-config"
30
31inherit autotools pkgconfig binconfig-disabled pythonnative ptest
32
33RDEPENDS_${PN}-ptest += "python-core"
34
35RDEPENDS_${PN}-python += "python-core"
36
37RDEPENDS_${PN}-ptest_append_libc-glibc = " glibc-gconv-ebcdic-us glibc-gconv-ibm1141"
38
39export PYTHON_SITE_PACKAGES="${PYTHON_SITEPACKAGES_DIR}"
40
41PACKAGECONFIG ??= "python"
42PACKAGECONFIG[python] = "--with-python=${PYTHON},--without-python,python"
43
44# WARNING: zlib is require for RPM use
45EXTRA_OECONF = "--without-debug --without-legacy --with-catalog --without-docbook --with-c14n --without-lzma --with-fexceptions"
46EXTRA_OECONF_class-native = "--without-legacy --without-docbook --with-c14n --without-lzma --with-zlib"
47EXTRA_OECONF_class-nativesdk = "--without-legacy --without-docbook --with-c14n --without-lzma --with-zlib"
48EXTRA_OECONF_linuxstdbase = "--with-debug --with-legacy --with-docbook --with-c14n --without-lzma --with-zlib"
49
50# required for python binding
51export HOST_SYS
52export BUILD_SYS
53export STAGING_LIBDIR
54export STAGING_INCDIR
55
56python populate_packages_prepend () {
57 # autonamer would call this libxml2-2, but we don't want that
58 if d.getVar('DEBIAN_NAMES', True):
59 d.setVar('PKG_libxml2', '${MLPREFIX}libxml2')
60}
61
62PACKAGES += "${PN}-utils ${PN}-python"
63
64FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/*.a"
65FILES_${PN}-dev += "${libdir}/xml2Conf.sh ${libdir}/cmake/*"
66FILES_${PN}-utils += "${bindir}/*"
67FILES_${PN}-python += "${PYTHON_SITEPACKAGES_DIR}"
68
69do_install_ptest () {
70 cp -r ${WORKDIR}/xmlconf ${D}${PTEST_PATH}
71}
72
73BBCLASSEXTEND = "native nativesdk"